Skip to:

Group/Personal Avatar issues

  • benny148148


    I’ve already submitted this issue to trac, but I’m hoping somebody else has had this problem too and found a temporary fix to it.

    Essentially what is happening is no crop tools are given when a user uploads an image. The uploaded image will show on the screen, but they are unable to crop it, and the “crop preview” is non-existent. This happens with both my user avatars and group avatars.

    Before anybody asks, I’m using the Trunk version 1202, I have GD Library and Image Magick installed, and I’m on a VPS, not shared hosting. If anybody knows what could be causing it I’d greatly appreciate the help!

    Video of problem:

Viewing 5 replies - 1 through 5 (of 5 total)

  • nicolagreco


    Are you loading js with other plugins?

    Burt Adsit


    Check the permissions and more importantly the ownership rights for the stuff in /blogs.dir/1/files/avatars/1

    Everything from /wp-content down. Does your apache user have create rights in that dir chain? apache might be ‘nobody’ or ‘apache’ or something else entirely. Depends on your server setup.

    Or like nicola suggests you’ve got some other js loading that is conflicting with the cropper.

    Any more updates on this. It is strange – I have the same issue, but only on one install (two other tesinstalls work just fine, same server, same setup). The permissions seem to be more than right (777). I had a conflict from a plugin with js, but I deinstalled. Still not working.

    I updated to the latest trunk r1248

    Could it be that something of that plugin is still “left”, although I deinstalled it…

    I saw a ticket which seems related to this – could that be it? Any solution yet? (there it is mentioned that it seems, that there is no loading of js at all… why?)

    I am desperate! Please help you GURUS :-)

    Avatars are just a very important thing and i am planning to go live soon…

    THANKS, Michael

    Here the (maybe) error in apache log:

    [Mon Mar 23 20:43:41 2009] [error] [client] ALERT-SIMULATION – configured GET variable name length limit exceeded – dropped variable ‘iterator_bindcontext_:_Prototype_K;____var_result;____this_eachfunction_value,_index_value_’ (attacker ‘’, file ‘/services/webs/’), referer:

    It’s crazy – I tried to figure that out for hours… no it works. It wasn’t a plugin, but a js-conflict from the theme. Strange is only, that it once worked, and then not anymore.

    For me the issue is solved… :-)


Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Group/Personal Avatar issues’ is closed to new replies.
Skip to toolbar