Skip to:

How do you update the permalinks? And update to what?

  • I’m new to wordpress and buddypress. I’ve completed a fresh install of wordpress and buddypress on my site, here:

    mod_rewrite is installed. None of the links work. The documentation for updating the permalinks after install is insufficient. Update to what? where? how? Can someone take a look and see what I’ve done wrong or suggest a fix for my problem? Thanks. :)

Viewing 9 replies - 1 through 9 (of 9 total)

  • LPH2005


    go to /wp-admin (the admin panel for WP) and find Settings menu on the left side, near the bottom. You should then see Permalinks as a submenu. Update that setting and see what happens.I prefer “day and name”

    Let us know.

    So… It’s not really “update”, but more of a “Change” to the permalinks. I had them set for day and name already. I get this on any link or button that is clicked:

    The requested URL /wordpress/activity/ was not found on this server. 404 error.

    Maybe something installed incorrectly? It’s a fresh install.



    I need assistance with this exact issue as well. None of the links work.

    On Yahoo Web Hosting. Permalink structure is as follows:


    Yahoo doesn’t allow for .htaccess files, so if Buddypress uses .htaccess, this won’t work for me. I’m hoping that isn’t the case.

    Clicking on any of the buddypress links leads to a 404 error message. I am able to find the directories in the theme folder that match however, so i suspect that the links are trying to get into those folders. I should mention that this happens in either the default BP themes, the child themes i’ve installed such as “unplugged”, and themes i’ve converted to be compatible like “sliding-door”, so from my understanding, this is not a theme issue

    Anyone got some assistance for us?

    Thanks in advance!



    Also have the same problem with my local installation.

    1) Installed WordPress: Worked
    2) Got Buddypress as a plugin.
    3) Got a message, that the .htaccess could not be changed due to missing permissions, so changed the permissions, then no error message appears
    4) Choosed the Buddypress default theme
    5) Choosed the permalink options

    = I also get tese 404 error messages (for example /wordpress/activity/)



    still waiting on a reply

    Boone Gorges


    There are some known problems with BuddyPress and “almost pretty” permalinks like index.php/blahblahblah. I know that @djpaul was looking at it at one point. In any case, it’s probably a BP problem at this point.

    Still digging as/when I get time. No awesome solution yet. Quick hack; if you require pretty permalinks, you could try removing index.php/ from the permalink setting and trying something like a htaccess rewrite



    i need help with this too! It sucks!

    @christinarule pursuant to my other comments on your other threads you really need to start a new topic if you have an issue, and you will need to be a whole! lot more descriptive of the problem; telling us you need help is a ‘Given’ telling us something ‘Sucks’ not at all helpful it may well do but if you want it sorted out tell us exactly why it sucks!

    My comments are for your benefit following them will get you the help you require not doing so and your posts will probably be passed over, it’s a busy tech forum and certain procedures need to be followed if needing the help of people here.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘How do you update the permalinks? And update to what?’ is closed to new replies.
Skip to toolbar