Skip to:
Content
Pages
Categories
Search
Top
Bottom

How to hide the toolbar for those who are not logged in


  • heliocorrei
    Participant

    @heliocorrei

    WordPress version: 6.0.2
    BuddyPress version: 10.4.0
    Link to my site: rcnvanguarda.com.br
    Theme: BuddyX Child

    Hello guys.

    In BuddyPress settings, I already unchecked the option (Show Toolbar to unauthenticated users), but the toolbar continues to appear even for those who are not logged in yet.

    If I can remove the menu with the “Activities, Groups and Members” options and only show it to those who are logged in, it would help a lot.

    Another question, how do I not display the timeline for those who are not logged in?

    And how do I make the person, when logging in to the network, go straight to the general timeline of the network?

Viewing 5 replies - 1 through 5 (of 5 total)

  • heliocorrei
    Participant

    @heliocorrei

    Hi, Anybody can help me?


    michaelabf
    Participant

    @michaelabf

    The link to your site does not work.

    If it helps, there are guides on how to remove items from the WordPress toolbar.
    Search “remove items from wordpress toolbar”


    heliocorrei
    Participant

    @heliocorrei

    Hi.
    Thanks for answering.

    That part of the tab that you said, I already removed it, but it’s not working.
    I will do a test.
    In the same toolbar I put two other options, Home and Privacy Policy.
    I’ll remove it and see if it works.
    But please, take a look at the link now, I’ll put it in full.

    Home

    Note that if you click on “Activities” in the menu bar it already shows the timeline and I need it to only appear when the person is logged in.
    Sorry, it’s my first post.

    Thanks.


    michaelabf
    Participant

    @michaelabf

    @helio …there is no Activities option showing in your menu/toolbar.
    Viewed on mobile.
    If you want to prevent not-logged-in users from viewing any Buddypress pages, you can use a plugin like “BP Members Only”


    heliocorrei
    Participant

    @heliocorrei

    Hello.
    Thanks for answering.
    The moment you didn’t see the “Activities” option, it’s because I was doing some tests.
    But thanks a lot for the plugin tip.
    It was exactly what I was looking for.
    This community is very good.
    Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
Skip to toolbar