Skip to:
Content
Pages
Categories
Search
Top
Bottom

I cant Access registration page

  • Profile photo of Solomonsun
    Solomonsun
    Participant

    @solomonsun

    Hello buddy gurus in the house.

    just recently, my buddypress registration page when loaded on the browser says:

    The page isn’t redirecting properly

    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    This problem can sometimes be caused by disabling or refusing to accept cookies.

    i have done everthing within my abilities yet no results. I uninstalled buddypress and reinstalled it, the same problem.

    What do i do?

    https://schoolhome.com.ng/

Viewing 16 replies - 1 through 16 (of 16 total)
  • Profile photo of djsteveb
    djsteveb
    Participant

    @djsteveb

    what does your htaccess include in it?

    switched to a default theme like 2014?

    using the basic, default /register/ or whatever? (or did you chage it to something custom at some point?)

    Go to settings -> permalinks – make a note of what they are set to..
    change it to some else like post=1223 – click save.. then change it back to the /postname/ or whatever.. save again..

    problem fix?

    Profile photo of Solomonsun
    Solomonsun
    Participant

    @solomonsun

    Thanks djsteveb for your prompt response.

    i have tried all that yet it isnt working.

    i use newspaper7 theme.

    i have deleted buddypress for like two times and reinstalled it but it doesnt seem like working.

    i dont know if the fault shuold be from the server, theme, wp4.7 or anything. am just fed up with it.

    i have tried opening the page with the following browsers: Chrome, Firefox and Opera still no result.

    what baffles me is that it was working perfectly before.

    Profile photo of danbp
    danbp
    Moderator

    @danbp

    Hi @solomonsun,

    what baffles me is that it was working perfectly before.

    This baffles me too, as you don’t say what happened “before”. Before what ? Who could we know that ?!!!

    Do you have a registration page and does that page have a correct slug ? For ex. /registration/ and not /registration-2/
    Have you setup pretty permalinks and resaved them again after the myterious “before action” ?
    Are you logged in when you try to access the registration page ? This is not possible – you must be logged out to access it.

    Profile photo of Solomonsun
    Solomonsun
    Participant

    @solomonsun

    Profile photo of danbp
    danbp
    Moderator

    @danbp

    @solomonsun,

    the url you provide doesn’t match! It would be great you indicate existing, or at least, working url’s.

    Check your htaccess, and see why you get an url containing www, while WordPress doesn’t use them by default.

    You could also read here if you’re on a single install.

    And some more details in this tutorial.

    Profile photo of Solomonsun
    Solomonsun
    Participant

    @solomonsun

    @danbp i dont understand please. the url http://www.schoolhome.com.mg/registration WAS what i was using to access my registration page before the issue arose.

    Maybe i should just give up on buddypress

    Profile photo of djsteveb
    djsteveb
    Participant

    @djsteveb

    @solomonsun
    – ” http://www.schoolhome.com.mg/” – comes up as server not found from where I am at.. so it does not seem that this url is valid / working.. if you go to that url it works somewhere? Is something on the web server locking it down where no one can access it but you.. or some other blocking system to prevent me or others from seeing your url?

    You might wan agive up on buddypress – for several reasons.. cuz it doesn’t get any easier – things are going to get harder as some point.

    you never posted what your htaccess file says in it.

    you never ” don’t say what happened “before”. Before what ?” – explained what you changed when it stopped working.

    sorry to hear it’s not working for you

    Profile photo of Solomonsun
    Solomonsun
    Participant

    @solomonsun

    2djsteveb the url is https://schoolhome.com.ng

    i only changed the wp page from registration to register

    Profile photo of djsteveb
    djsteveb
    Participant

    @djsteveb

    @solomonsun – have you gone to:
    admin dashboard
    settings -> buddypress –
    then the tab near top: “pages”

    scroll down to registration and see which page is selected there? tried changing it and saving it, then change again and save again perhaps?

    Steve
    ps- this is not the netowrk superadmin dashboard, but the regular main admin dashboard if you are in multisite setup I think.

    Profile photo of Solomonsun
    Solomonsun
    Participant

    @solomonsun

    @djsteveb thanks for your time and prompt response. i have done everything you mentioned above, still no solution. Am evening trying to install buddypress again because i deleted the former, even though i have done this before.

    my browser just keep showing this

    The page isn’t redirecting properly

    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    This problem can sometimes be caused by disabling or refusing to accept cookies.

    Profile photo of Solomonsun
    Solomonsun
    Participant

    @solomonsun

    i just reinstalled buddypress now and found out that the pages (e.g activity, group, activate etc)that usually comes with it doesnt exist on my pages anymore (am just seeing the pages i created for myself)

    Profile photo of djsteveb
    djsteveb
    Participant

    @djsteveb

    I would change permalinks, save, then change back and save..

    then – make a list of other plugins you are using, and which theme – try with all other plugins disabled.. and the 2014 (or 15 – default) theme.

    does it work?

    if not delete bp – and get your regular wordpress to work. remove any pages you don’t need – change permalinks.. basically getting a fresh install that works just as wordpress.. change permalinks twice.

    then install bp – and run through the process of assigning pages, and all that – and check permalinks twice..

    I would be it’s a theme or other plugin causing the conflict at this point.. if your htaccess is fresh anyhow..

    Profile photo of Solomonsun
    Solomonsun
    Participant

    @solomonsun

    well said @djsteveb. thanks for your support and kindness. if i try those steps above (though i dont understand all of them) and it didnt work, i’ll say goodbye to buddypress.

    Much love from Nigeria

    Profile photo of Solomonsun
    Solomonsun
    Participant

    @solomonsun

    hello everyone, i want to use the medium to thank you for your support and unmerited asistance. i finally resolved the issue.

    thanks @djsteveb

    Profile photo of hurior
    hurior
    Participant

    @hurior

    How do you solve it, I have the same problem…
    Thanks!

    Profile photo of Solomonsun
    Solomonsun
    Participant

    @solomonsun

    hello @hurior. i made sure i deleted buddypress from my cpanel and Plugin tab in wp-admin. then i reinstalled buddypress, manually created pages like member, profile, registratoin, activation, etc. then i went to settings > buddypress > pages > and associate the pages there with the pages i created and saved them. thats all

    Check it out https://schoolhome.com.ng

Viewing 16 replies - 1 through 16 (of 16 total)
  • You must be logged in to reply to this topic.
Skip to toolbar