Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Fixed] I can’t create groups page keeps reloading


  • dopeboy
    Participant

    @dopeboy

    I could create groups then all of a sudden I cant, each time I want to create a new group it keeps reloading the page https://www.example.com/groups/create/step/group-details/ I also tried going via admin but it redirected me to the user UI and still the same problem. Maybe due to a change to WordPress 4.9? Because before the upgrade I was able to create groups even users could, but I just figured that it stopped working and the only change is the WP Core update.

    BTW I was using BuddyBoss Theme, I have also switched to Twenty Seventeen, but still exactly the same problem.

    Any way I can handle this problem?

Viewing 11 replies - 1 through 11 (of 11 total)

  • dopeboy
    Participant

    @dopeboy

    HELP!


    Boone Gorges
    Keymaster

    @boonebgorges

    A few things to check:

    1. After submitting the first page of the group creation process, is the group actually created in the database? Check Dashboard > Groups, or the wp_bp_groups database table if you know how.

    2. Check your browser cookies to see if the bp_new_group_id and bp_completed_create_steps cookies are set. If so, please share the details, especially the Domain and Path.

    3. If you have access to PHP error logs on your server, please check them for related errors. Otherwise, consider enabling WP_DEBUG to see if anything relevant is shown after submitting the first step of the creation process.


    dopeboy
    Participant

    @dopeboy

    1. Didn’t see anything via DB and Dashboard
    2. Didn’t see anything in cookies
    3. The only errors I saw I don’t think it concerns bp-groups.

    Notice: Use of undefined constant MC_TEXT_DOMAIN - assumed 'MC_TEXT_DOMAIN' in /home/site/public_html/wp-content/plugins/bpchat/admin/class-bpchat-options.php on line 41
    
    Notice: Undefined index: heartbeat_control_location in /home/site/public_html/wp-content/plugins/heartbeat-control/heartbeat.php on line 54
    
    Warning: in_array() expects parameter 2 to be array, null given in /home/site/public_html/wp-content/plugins/heartbeat-control/heartbeat.php on line 40
    
    Warning: in_array() expects parameter 2 to be array, null given in /home/site/public_html/wp-content/plugins/heartbeat-control/heartbeat.php on line 42
    
    Notice: Undefined variable: bpchatBgc in /home/site/public_html/wp-content/plugins/bpchat/controllers/class-bpchat-script-controller.php on line 244
    
    Notice: Undefined variable: bpchatTip in /home/site/public_html/wp-content/plugins/bpchat/controllers/class-bpchat-script-controller.php on line 246

    Boone Gorges
    Keymaster

    @boonebgorges

    If you don’t see anything in your cookies, then that’s the source of the problem. BP uses cookies to indicate that you’re moving through the group creation process, and if it doesn’t see these cookies, it sends you back to the first step.

    So, the question is why those cookies aren’t being set. Things to look at:

    1. I assume that at least some cookies are being set on your site, or you wouldn’t be able to log in 🙂 Are other BP-related cookies working? For example, if you go to the group directory and change the “Order by” dropdown to, say, “Newly Created”, is a browser cookie created bp-groups-scope? A quick test is to do a hard-refresh of the groups directory, and see if your selection sticks.

    2. If other cookies are being set, it could be a path-related issue. Have you set a custom COOKIEPATH in your wp-config.php file? It could be that cookies are being set in such a way that they’re inaccessible to certain pages of the group creation process.

    3. Have you tried in other browsers? Or in private browsing windows? It could be that this is being triggered by privacy settings of one sort or anotheer.

    4. You showed some WP_DEBUG errors that (as you surmise) are unrelated to the problem. Are those shown when you first visit the group creation page, or *after* you’ve submitted the first step? It’s the submission process I’m concerned about, since the groups aren’t being created in the first place.


    dopeboy
    Participant

    @dopeboy

    1. Nothing didn’t see a cookie, didn’t work
    2. Didn’t set a custom cookie path
    3. Tried other browsers, even with a mobile phone still the same
    4. Errors after I clicked Create Group and Continue.

    Can’t even create a group from the dashboard. It takes me to front-end UI the moment I click on create group from dashboard


    dopeboy
    Participant

    @dopeboy

    [RESOLVED] I went to BuddyPress options in WP Dash and the disabled User Groups Component and reenabled it then I was able to pass the first step and created a group. It works fine and normal now.

    But I don’t know if you understand why it did that and why what I did fix the issue. If you do, could you explain to me? Thanks


    Boone Gorges
    Keymaster

    @boonebgorges

    Very odd. It sounds like, when you initially installed BP (or activated the Groups component), it didn’t properly install the database tables. I have not seen that happen before, but I’m glad that toggling the component resolved it.


    dopeboy
    Participant

    @dopeboy

    Sorry, I don’t think that was the problem. See initially the group I wanted to create was named D'Casa Restaurant and bar But the one that I tested with didn’t have any special character. I just retried it again with the special character and the problem repeated itself. So I think it was a problem of the group name having a special character ' . Sorry for the confusion earlier.


    Boone Gorges
    Keymaster

    @boonebgorges

    Ah, interesting.

    1. If you’ve got access (through the mysql command line tool, or through PHPMyAdmin, check the character set and collation https://makandracards.com/makandra/2531-show-the-character-set-and-the-collation-of-your-mysql-tables There may be something funny going on there.

    2. Do you have the same problem with other content? Can you post a private message with a special character in the subject line? A blog post with a special character in the title?

    These items will help narrow down whether it’s a problem with bp-groups, or a database-level config issue.


    dopeboy
    Participant

    @dopeboy

    1. I am not that convenient with MySQL, I think I will just leave it for now.
    2. No problem with other content


    bbddev
    Participant

    @bbddev

    Hello,
    I Have similar error with creations groups.
    In my wp-config.php, I have this: define(‘COOKIEPATH’, ”);
    I only correct the error after comment this line.
    I opted to delete all entry in with cookie word in my wp-config.php and continued work.
    I hope this can help some.
    🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.
Skip to toolbar