Skip to:

“Join Group” link does nothing on my site


    WordPress 3.0.1
    thematic theme
    buddymatic theme 1.2
    early morning child theme 0.2

    I’ve created a test user and tried to join the two groups that I’ve created on my site with another user. When my test user clicks the “Join Group” link the link disappears and nothing happens. This problem also happened on the “request membership” link for a private group. I was able to get the “request membership” to work by turning off all my plugins. After turning off all the plugins the “Join Group” button still doesn’t work though.

    Any ideas?

Viewing 12 replies - 1 through 12 (of 12 total)
  • From what i’ve read I think It’s ok to bump a post once a day. If this is not the case please let me know.

    Profile photo of r-a-y


    What happens when you use the default BuddyPress theme?

    Does the “Join Group” link work then?

    Bingo. Default BuddyPress theme makes the “Join Group” button work. I totally forgot to put the default theme on. I’ve turned the “Early Morning” theme back on now.

    How would I go about figuring out what the problem is? Any suggestions?

    Could any one give me hand with a solution to this problem? The “early Morning” Child theme is not allowing the “Join Group” link to work. I’m not really sure how I would diagnose the problem.

    Profile photo of r-a-y


    To be fair, this is a third-party theme, I’d recommend contacting the authors of that Buddymatic child theme:

    Also follow the instructions listed in the post.

    I followed the instructions when i first installed it but I didn’t notice if I had this problem when it was first installed.

    The support on the early morning page isn’t really there. I’ve posted this question in the Thematic theme forum though:

    I’ll post an update when I figure it out.

    I heard back from the author of Early Morning and he said I should contact the author who edited his theme to work with buddypress, . The only problem is that the last time an admin offered support at this link, was in January. I would most appreciate a hand from someone out here. Here is a recap of the problem:

    If I click on the “join group” link on this page: the link disappears and nothing happens.
    If I right click the link, copy the link and paste it directly into the address bar, it works.

    Does anyone have an idea of why a copied link would work when directly clicking on it wouldn’t?

    Update: I’ve created a test user for anyone to log in to my site and try the “Join Group” button.

    User: durham123123
    pword: 123123

    Any help would be much appreciated.

    It seems to work now. How did you fix it?

    FYI, I fixed mine by manually forcing “ into my theme files. Put it right above the actions.

    I fixed it by switching themes. I could never figure out how to make the button show so I just switched to a theme that works. I’m really happy with bp-slick.

    Profile photo of gwu123


    did anyone figure out this?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘“Join Group” link does nothing on my site’ is closed to new replies.
Skip to toolbar