Skip to:

Language file acting up?

  • mrgiblets


    Hey guys,

    I’m going through and changing the text displayed by buddypress by creating custom PO & MO files as described here –

    It’s all working great but I’ve stumbled upon something strange.

    For some reason I can’t change the following string :

    %1$s posted an update in the group %2$s

    No matter what I set in the translation field :

    %1$s posted in the group %2$s

    ….it always displays the original text :

    username posted an update in the group groupname

    I’ve checked to make sure it’s not repeating anywhere else in the MO file but, nope, there is only one instance of this string.

    Any suggestions as to why I can’t translate this particular string?

Viewing 6 replies - 1 through 6 (of 6 total)

  • Henry Wright


    Hi @mrgiblets

    That’s slightly odd. You’d expect to see the change if the rest of your translated strings are working.

    Are you working from the latest BuddyPress .pot file?



    Hey @henrywright,

    Yes it’s very strange, I have changed multiple other things in my new POT file but for some reason this particular string won’t translate?

    Try it yourself if you like, at least then I’l know if it’s just my install or a script bug.



    Hey @henrywright,

    I, too, am having a similar issue. I followed the instruction from and updated my language to change ‘Groups’ to ‘Cluster’. It worked fine for a week or so and something happened.

    I tried to do it over from scratch (starting from step 1 again) but it still wouldn’t work.

    Please help.

    Thank you,



    When your custom language file doesn’t contain a correct header version, it will be overwriten at each BP update.

    To avoid this, you have 2 solutions.
    – completely deactivate automatic translation upload, which will affect the whole site: theme and plugins.
    – keep a safe copy and upload it to the site AFTER the update. Tehn if something is missing or no more translated, you can update your version from the pot file shipped with BP.

    If you use a cache, you have to clear it before installing a custom version. You must be sure that your wersion is running, in any case.



    That is a good point, it probably had something to do with the update.

    I tried doing it again from the buddypress.pot file in wp-content/plugins/buddypress but it doesn’t work.

    Am I missing something?



    Is there a possibility that my buddypress.pot file isn’t working properly? I’m using the Kleo theme. Thank you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Language file acting up?’ is closed to new replies.
Skip to toolbar