Skip to:

No Group Forums

  • jugoretz


    I really want to make this work, and really can’t. ANY help will be appreciated, honest!

    I’ve followed every single step, I’m positive, several times (deleting everything and trying again each time).

    I think my problem is very similar to what’s happening to others in this thread , although not precisely the same, but none of these solutions seem to work.

    Let me lay it out…

    I’ve got a working WPMU 2.7.1 installation at . BuddyPress is working fine in there (1.0).

    BBPress (the alpha 1.0) is installed and working fine at

    The integration in terms of user accounts is working fine, it seems, because all the WPMU users are listed in bbPress.

    I’ve got the plugin in my-plugins in bbPress and activated, and the two plugins in wpmu are activated.

    I’ve got the boxes for XML-RPC and pingbacks ticked in bbPress.

    I’ve got forums enabled in Component Setup and the information all entered in Forum Setup (and checked and reentered) in the admin of WPMU, with a new user created and made an administrator in bbPress and that user entered and that user’s password entered in bbPress Integration in the Settings in WPMU’s admin.

    I’ve added the appropriate line about user-switching in bb-config.php.

    But I can NOT seem to get group forums to set up at all in BuddyPress.

    When I create a group, instead of the option to enable discussion, I get the warning “Attention Site Admin: Group forums require the correct setup and configuration of a bbPress installation.”

    In an existing group (there’s only one) or any of the new groups I try to create, there is NO option for enabling or disabling discussion in the Group Settings.

    There’s a “Forum” button for each group, as if there were a Forum there, but when trying to post to that forum, I get “there was an error posting that topic” in a red bar.

    Basically, no forums are able to happen at all.

    Following the advice in the other thread, I tried the xml-rpc check with /oci-bp-sayhello.php .

    That gives this error -32300 >> transport error – HTTP status code was not 200

    which is not exactly the same as what others were seeing. It’s not a 404 error at all.

    But maybe that gives a clue? I did check the /etc/hosts file, on the recommendation of others in another thread, but there IS an entry for my own server, with the correct IP address.

    Any ideas or suggestions? I’ve spent a couple of days on this–much searching of the forums and googling, and I seem to be stumped. Even questions or seemingly obvious points that I might have missed would be welcome at this point!


Viewing 14 replies - 1 through 14 (of 14 total)

  • John James Jacoby


    The Forums link appears regardless of the forum physically existing or not. Once the BuddyPress forums plugin is turned on, it turns on all of the links also.

    Regarding the steps you’ve taken, they’re all correct, so don’t second guess yourself there.

    My guess is this is a PHP Memory error. Your host probably has you defaulted to 8MB, and you’re going to need much more than that allocated to run WPMU and XMLRPC.

    In your .htaccess files (both WPMU and bbPress) put

    php_value memory_limit 32M

    You can also alternatively make a php.ini file, put that in your root directory, and inside it put

    memory_limit = 32M

    If it still doesn’t work, report back.



    Thanks, John. I did try that, too, although I didn’t mention it. memory_limit is at 32M already.

    I’m wondering if there’s an error log I should be looking at somewhere? Or other debugging steps I can try?

    John James Jacoby



    Can you check with your web host and ensure that they have XML RPC enabled on your PHP install?

    Otherwise you can make yourself a <?php php_info(); ?> file and check for yourself.



    I’ve got a phpinfo file, but not sure where in there to look.

    I do see this

    xmlrpc_error_number 0 0

    xmlrpc_errors Off Off

    which isn’t meaningful to me.

    Sam Bauers


    I don’t think bbPress XML-RPC relies on PHP having an XML-RPC extension turned on.

    Other peoples problems have been related to their hosting company not allowing remote calls to be made to the same server.

    When this is the case the host generally recommends running the sites on two separate servers somehow.

    There is some craziness in the way the forums component is architected to integrate via XML-RPC, but it got the component over the line for 1.0. Better solutions should probably be sought for the next release.




    This a dedicated server and I can allow remote calls to it from itself if they’re not being allowed now. I mean if I knew how to! Where would that be disabled, how could I tell, and what would I need to change to enable it?

    Or I guess wait for the next release–I’m really hoping to roll this out large-scale when the students return in the fall. But that seems like a tight time-frame for the next release.




    I have had the same problem for the last few days, using wpmu2.7.1, bp1.0, bb1a6, bbpress integration plugin and buddypress-enable.

    The steps that seem to have solved the problem:

    1. Delete all cookies.

    2. Go to bbpress, register a new user. Log into bbpress as keymaster and give define that new users as admin.

    3. Create a new forum in bbpress (any new forum).

    4. Log into wpmu, go to forums setup and use the new user you just created.

    5. Delete all cookies.

    5. Log in, try starting a new group in wpmu.

    I’m trying to pinpoint which of these steps did the trick to reuse it beyond my test installation.

    Let me know whether it works for you as well, and if you figure out what the reason is.

    Good luck



    One more thing, make sure that you have pingbacks and XML-RPC check in bbpress.



    Thanks, Lederman, but that did not work for me!




    O . M . G .

    After 2 DANG DAYS of going thu EVERYTHING, i mean every dang file. I could rewrite it i’ve been thu every line of code.

    I was having the VERY same problems Jugoretz was having and GUESS WHAT WAS WRONG?!?!?


    You have to use the bottom link on bbpress download site for the latest beta or alpha, RC whatever the heck it is.

    You can’t use the “normal” release… as of this posting.

    geez did i miss the versions? Did someone really already say this!?


    Convert it… here we go

    Just nuke all the files in your /bbpres_install_dir

    Leave your database file alone, it will fix them for you.

    copy over the CORRECT VERSION of bbpress BETA/ALPHA/RC whatever it is now… (bottom link on download from bbpress)

    visit your forum again, it’ll give you the install page again, go thu the install, i just selected the keymaster account i had setup and then hit up the settings page, the dang options they say to click ARE THERE now (go figure) and then enter in your salts it tells you what to do (simple) then…

    (What i did) For the hell of it i made a new forum just to make sure… like “hi” or something…

    Said ok, let’s try again (with sleepy eye’d look on my face)

    when into the WPMu and checked and submitted the settings again for my keymaster account in the forum options.

    Then… When straight to the groups, made me a new group and BAM it’s it in the forums, I’ve got the forum icon on the left in and an option to then off discussions…

    I’ve been up like 21 hours or something, sorry if my post is WACK, but guys for about 2 days i thought i was losing my mind and what just about to give up on it all. Everything I read sounded right but didn’t work, i must of flipped the “enable wire” switch like 4000 times, geez…

    Anyways, these problems are clearly people not using the ***LATEST*** version of bbpress!

    wow, my head hurts.

    /end of rant and rave



    $O.M.G = “geez had me del cookies, flippin’ switches, checking salts, eating cookies, half awake, stop; play some cod4 or 5, go at it again… get pissed, del everything started over, del more cookies, watching “install videos for hours” read just about every help page on the net about BBpress, wondered where my forum link was, flipped the wire switch a few more times, got mad at firefox a few times, closed it, porn surfed, wife got mad again, slapped me on the head and BAM new idea, what version of BBPress am i running? “

    echo $O.M.G

    my new shell login…



    Nope. Hate to say it, but that was one of the first things I tried. It still, even with the correct version, doesn’t work for me. :-(



    dunno if i can do this our not, but this is mine.

    All i did was install latest WPMu, Buddy and rc1 bbpress



    “Enable Pingbacks” for BBP & WPMU

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘No Group Forums’ is closed to new replies.
Skip to toolbar