Skip to:

no links work at all (noob)

Viewing 9 replies - 1 through 9 (of 9 total)

  • Burt Adsit


    When running on windows you have to manually enter the subdomains in the ‘hosts’ file.


    A sample from my hosts file: localhost

    The reason is you are not running a DNS server to resolve the domains to an ip address.

    yeah, I’ve already registered my sub domains. It was just alumniconnect.localhost. But it’s not like my subdomain is getting a 404 error, they pages are (news, members, etc).

    I have no idea what to do.

    defining the URL (negating mod_rewrite, in case that was the problem) I did:


    it loads, surprisingly, but reads the error:

    “Fatal error: Call to undefined function get_header() in C:localhostalumniconnectwp-contentthemesbuddypress-homeblog.php on line 1”

    Burt Adsit


    The only problems are ‘news’, ‘members’, ‘groups’ buttons in the home theme? All else works ok? I don’t know what blog.php has to do with anything. If you hit ‘news’ bp uses ‘index.php’ to display latest posts on that blog.

    If members and groups directories aren’t running at all then you should be getting an error msg.. ok stop..

    I re-read your msg and you are getting 404s but things are running. Ok. It helps to actually read the other person’s msg. (sigh)

    The 404’s are a known problem when running the various directories. A workaround to eliminate the 404s is to create pages with the same slug as the directory slugs.




    Three pages with the above slugs should eliminate the 404s. They just serve as placeholders.




    my installation WPMU + BP worked fine by 1&1.

    But same issue, every link on the homepage goes to a 404.

    I created 3 pages with slug like : but still the 404 page on every link

    any idea ?


    I have the same problems

    How do i create pages with the same slug as the directory slugs?

    Burt Adsit


    Latest trunk r850 has fix for 404 directory problems.



    Thank you burtadsite for having taken my issue in consideration.

    @ swift I solved my problem with 404 tonight : it was something with the permission (755 everywhere, insn’it dangereous ?) and/or the ht.access (php 5) and/or the permalinks (i went back to standard URL), i don’t know but it works fine yet (i just cannot reach the new blogs but i will post it somewhere else)

    to create pages with placeholder slugs, you have to choose standards permalinks then go to write a page (page not article), then just make a page named (titled) “members”, then “blogs”, then an other one with “groups”

    see you

    @ burtadsit that still didn’t fix my problem I updated to trunk 857.

    @ Ism_267 what is the (standard url) the Default permalink?

    I just created a page and set the permalink to Custom Structure /post-name/

    however it goes to page not found

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘no links work at all (noob)’ is closed to new replies.
Skip to toolbar