Skip to:
Content
Pages
Categories
Search
Top
Bottom

page not found errors


  • Jonathan Carroll
    Participant

    @jace0228

    I am getting 404 page not found errors during the group creation process and profile edit process. I note several others are experiencing this as well. The community appears silent on a solution at this time. I have the latest versions of buddy press and wordpress and am using godaddy for hosting.

    Does anyone have any thoughts or ideas on how to get this working. I am happy to try anything anyone suggests (Aside from barking like a dog)

    Thanks!

Viewing 16 replies - 1 through 16 (of 16 total)

  • Paul Wong-Gibbs
    Keymaster

    @djpaul

    Oh man, barking like a dog would have fixed it ;) Oh well…

    1) What versions of WordPress and BuddyPress?
    2) What are the file permissions on .htaccess? Can the webserver write to it? If you do have to change the permissions, then after doing so, go back into WordPress and change the permalink settings to something else. Then set it back to what you wanted the permalink to be and try again (this will re-write the relevant part of the htaccess).
    3) What other plugins are you running? What theme are you using? If it’s custom, what sort of thing do you have in its functions.php?
    4) What type of GoDaddy hosting are you using?

    If you’re using WPMU aka Multisite on GoDaddy, as far as I can tell, you’re in for a lot of trouble :(


    Jonathan Carroll
    Participant

    @jace0228

    1 – WP Version 3.0, BP version 1.2.5.2
    2 – I cannot locate an .htaccess file anywhere. I did some reading online and found that the .htaccess file doesnt exist unless needed by wordpress for permalinks? If this is the case perhapos the godaddy permissions are not allowing this file to be created? If thats true, I can call godaddy and ask them about this, unless you know how to enable this functionality?
    3 – Theme – Standard BP Theme | Plugins: A lot, but I had tried disabling them and getting the same error. Here is the list: Add Logo to Admin, Akismet (disabled), AWPCP, BP Events (Disabled), BuddyPress, BuddyPress Community Stats, Email Login,
    Fast and Secure Contact Form, Google XML Sitemaps, Jet Event System for BuddyPress (Disabled), Members Only, Secure WordPress,
    SI CAPTCHA Anti-Spam, Welcome Pack, WP-Mail-SMTP
    4 – Godaddy, shared, Windows ( ica change off of windows if needed, this is not critical for me)


    rich! @ etiviti
    Participant

    @nuprn1

    IIRC – godaddy caches htaccess files


    Paul Wong-Gibbs
    Keymaster

    @djpaul

    Ah, Windows. What is your hosting type? Are you on IIS7?

    If you set visit /wp-admin/options-permalink.php on your site, and pick any setting that isn’t “default”, that’s all you should do. It should then create a .htaccess file for you.


    Jonathan Carroll
    Participant

    @jace0228

    I had already changed my permalinks option to day and name. I changed it again, and then back to day and name. I still do not see this file, and I also am still having the problem. just so we are clear, where should this file be created, and is the entire file name “.htaccess”?


    intimez
    Participant

    @intimez

    @jace0228

    .htaccess is the exact file name – maybe it’s hidden


    sak1968
    Member

    @sak1968

    I am having the same issue. Any fix yet. I thought the file web.config is what we should be concern with for mod_rewrite for IIS and not .htaccess? Any help?


    Paul Wong-Gibbs
    Keymaster

    @djpaul

    @jace0228
    What version of IIS is your host running?


    Jonathan Carroll
    Participant

    @jace0228

    IIS 7.0
    Windows, Shared hosting
    ASP.Net 2.0/3.0/3.5
    PHP 5.x


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    I currently develop BuddyPress locally using Windows IIS7 and PHP 5.3; haven’t experienced these issues at all, but it’s possible a combination of .htaccess and web.config files might be gumming something up.

    Not sure if this is helpful, but this is currently the web.config that I’m using.

    https://codex.buddypress.org/developer-docs/iis7-web-config/


    Jonathan Carroll
    Participant

    @jace0228

    John, I copied your web.config file to my server and am experiencing the same problem. I have found several others here on buddypress experiencing the sdame thing and it seems thye are all hosted on Godaddy as I am:

    Here (this describes my problem exactly)
    https://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/404-flashes-then-redirects-fine-when-creating-groups/

    I have seen others as well.

    Any further thoughts?


    r-a-y
    Keymaster

    @r-a-y


    Jonathan Carroll
    Participant

    @jace0228

    ray, I attempted the solution you recommended. You fixed my problem. I would like to point out though, that it initially caused an error (bringing the whole site down), because the pasted text created what appeared to be italicized quotes, instead of straight quotes. Once I changed these to straight quotes, the problem was corrected.

    Thank you all (Ray, Paul, John) for helping. I will post this solution to the other post with issues as well, and I will also learn how to make the mini plugin you recommended so I can learn and help others.


    r-a-y
    Keymaster

    @r-a-y

    @jace0228 – Cool! Glad this works. You’re the second person to confirm the fix.

    Here’s the fix bundled into a quick plugin:
    http://buddypress.pastebin.com/download.php?i=S8e3t2Se (updated July 24th, forgot to wrap a !function_exists call around the function)

    Save as a PHP file and add it to /wp-content/mu-plugins/ or add it to the regular plugins directory and activate network-wide.


    Paul Wong-Gibbs
    Keymaster

    @djpaul

    RE: https://trac.mu.wordpress.org/ticket/906

    I’d love to know why this doesn’t affect everyone on IIS.


    isabellagucci
    Member

    @isabellagucci

    I installed the plugin, followed your instructions and I keep getting this error message when I activate the fix “Fatal error: Cannot redeclare wp_redirect() (previously declared in /home/thetrans/www.xxxxxxxxxxxxx.com/wp-includes/pluggable.php:874) in /home/thetrans/www.xxxxxxx.com/wp-content/plugins/vJfxs8VV.php on line 33”

    Does this fix not work for regular wordpress people who are not running MU. This page not found issue has happen over 50 times in the past hour. No matter what I do, not matter if I am trying to activate a plugin, or write a simple post this error message keeps popping up. Please let me know if there is a fix for this because unfortunately for me it’s not working. I have the most current version of wordpress and buddypress. Thanks

Viewing 16 replies - 1 through 16 (of 16 total)
  • The topic ‘page not found errors’ is closed to new replies.
Skip to toolbar