Skip to:
Content
Pages
Categories
Search
Top
Bottom

Pagination does not work for any member list in groups.


  • amiya36
    Participant

    @amiya36

    On the buddypress members list for groups when I click on page 2 it sends me back to the main member list directory? It seems that none of the lists work correctly excerpt maybe activity. Other wise once you get past the first page of anything on buddypress it just goes where it wants. Which sucks because i spend 100’s on themes all buddypress for nothing

    I have tried plugins,
    I have changed the list count and tried a few so-called pagination fix codes nothing seems to be working

Viewing 7 replies - 1 through 7 (of 7 total)

  • Venutius
    Participant

    @venutius

    I’ve just looked at a group on one of my sites and pagination of group members works. So it’s something up with your install. Have you paired back the install to just BuddyPress and a default theme?


    amiya36
    Participant

    @amiya36

    buddypress default theme? I have not seen one of those since 2012 do they even work?


    vapvarun
    Participant

    @vapvarun

    @amiya36 try with default WordPress, Twenty Seventeen theme. You can also test in preview mode without activating it.


    amiya36
    Participant

    @amiya36

    I even tried the member types plugin and that list doesnt even work after the first page it always goes back to the main directory? Do you think it might be because my site is installed as a sub domain?


    amiya36
    Participant

    @amiya36

    my error log?
    WordPress database error Unknown column ‘profile’ in ‘where clause’ for query SELECT a.* FROM wp_buddyboss_media_albums a WHERE a.user_id=886 AND ( a.group_id NOT IN ( SELECT id FROM wp_bp_groups WHERE status != ‘public’ )
    OR a.group_id IS NULL ) AND ( a.privacy IN ( ‘public’) ) AND a.id IN (profile) ORDER BY a.date_created DESC LIMIT 0, 20 made by require(‘wp-blog-header.php’), require_once(‘wp-includes/template-loader.php’), include(‘/themes/woffice/buddypress.php’), the_content, apply_filters(‘the_content’), WP_Hook->apply_filters, bp_replace_the_content, apply_filters(‘bp_replace_the_content’), WP_Hook->apply_filters, BP_Members_Theme_Compat->single_dummy_content, bp_buffer_template_part, bp_get_template_part, bp_locate_template, load_template, require(‘/themes/woffice/buddypress/members/single/home.php’), bp_get_template_part, bp_locate_template, load_template, require(‘/themes/woffice/buddypress/members/single/plugins.php’), do_action(‘bp_template_content’), WP_Hook->do_action, WP_Hook->apply_filters, buddyboss_media_template_albums, buddyboss_media_load_template, include_once(‘/plugins/buddyboss-media/templates/members/single/buddyboss-media-album.php’), buddyboss_media_has_albums, BuddyBoss_Media_Albums->__construct, BuddyBoss_Media_Albums->fetch_albums


    Venutius
    Participant

    @venutius

    What does the error log look like with only BuddyPress active and with the 2017 theme?


    amiya36
    Participant

    @amiya36

    Here is what I did that worked! Installed Buddypress member types and kicked groups to the curb because the types plugin paginates perfectly! Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.
Skip to toolbar