Skip to:

Plugin could not be activated because it triggered a fatal error.

  • mariahneu


    Fatal error: Cannot redeclare bp_activity_install() (previously declared in /home/bt4t/public_html/site3/wordpress-mu/wp-content/plugins/buddypress/bp-activity.php:28) in /home/bt4t/public_html/site3/wordpress-mu/wp-content/plugins/buddypress/bp-activity.php on line 102

    Now what? :S


Viewing 11 replies - 1 through 11 (of 11 total)

  • Jeff Sayre



    First of all, we need some additional information:

    1. Which version of WordPress Mu are you running?
    2. From where (provide link) did you download WPMU?
    3. Which version of BuddyPress are you running?
    4. Did you open any of the BuddyPress files?
    5. Did you alter any of the BuddyPress files?



    I have this problem… triggered by the bp-events plugin (version 1.0).

    1. WPMU v2.7.1

    2. The WPMU site :)

    3. BP v1.0

    4. Nope

    5. Nope

    I installed bp-events v0.57 following the instructions in the Readme (I downloaded from here: When I activated that version it was fine. Then I used the automatic upgrade feature which said v1.0 was available.

    Upon re-activation I received the above message, like Mariahneu.

    I’ll roll back to 0.57 anyway, but any ideas?

    Burt Adsit


    I turned off the red light on this thread.

    mariahneu and philpeter seem to be having similar problems. mariahneu hasn’t responded and philpeter doesn’t seem to be having problems directly related to bp.

    @philpeter you should get Erwin’s attention through whatever support mechanism he has for his plugin. Your question is just buried in a thread that is going to be ignored. Start a new topic to get the attention of the plugin author. Use a descriptive title. Erwin is never gonna find your issue.


    I just received this error while trying to install Buddypress on a fresh install of WPMU 2.7.1. I was using the “add plugin” feature so I assume that I am getting the latest version of Buddypress (1.0).

    Per the questions above, I installed per directions and made no modifications except to move the bp_themes folder to wp_content as instructed. I opened no Buddypress files.

    So it looks like this problem is alive and well. I’m at a dead halt with Buddypress.

    @Eric, are you trying this with any other plugins other than BP? If you are, move those plugins out the way for the moment. It’d be handy to know when exactly you get this error message, too.


    There were no plugins activated.

    The message was: Fatal error: Cannot redeclare bp_activity_install() (previously declared in /home/public_html/wp-content/plugins/buddypress/bp-activity.php:28) in /home/public_html/wp-content/plugins/buddypress/bp-activity.php on line 102

    Now I get the “white screen of death” just by ftp-ing the buddypress folder into my plugins folder????

    Strange thing… this happened to me as well. I deactivated all the plugins (including those in the mu-plugins folder), tried reactivating and it started with no problems. From that point I could reactivate all my plugins and it worked.

    However, I think I fixed it because I got a similar problem when trying to add media to a post from the media library.

    The issue lies in the require statements, in the case of the media library it was within the bp-themes. If you change the require statements to require_once in the bp-themes folder it starts working.

    Mods, I am working quite heavily with BuddyPress atm, if there’s any way I can contribute to the core code please let me know.



    Cannot redeclare bp_activity_install just tried upgrading got same error. Removed plugin and ftpd 1.01 went to activate same error. I Cannot get buddypress to work now on one of my sites…

    Beware befor upgrading…..

    Burt Adsit


    1.0.2 has a new activity table structure. Visit the wpmu back end as Site Admin to upgrade your tables after uploading 1.0.2.

    Roger Coathup


    Same problem for me as well.

    @Burt: in wpmu back end… site admin, is it simply a case of hitting the ‘upgrade’ button?

    No, you just literally have to go into the /wp-admin/ backend. Any page, just once, you don’t have to click anything.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Plugin could not be activated because it triggered a fatal error.’ is closed to new replies.
Skip to toolbar