Skip to:

"Plugin could not be activated because it triggered a fatal error"

  • zageek


    This is driving me nuts. I think I started a topic on it a few weeks ago but I have been busy with other stuff. I can’t seem to find the topic I created a while ago.

    I am running WPMU 2.9.1.

    After doing an upgrade on BP from 1.1.2 to 1.1.3 on a previous version of WPMU(2.8.x I think) I got a fatal error. It said something about a function missing somewhere or something.

    I have upgraded WPMU to 2.9.1 and tried to activate BP and I get this error again, only now I get “Plugin could not be activated because it triggered a fatal error” and it doesnt give me any specific details of where the error is.

    What would the best recourse be, should I delete and reinstall BP all over again? Or should I wait for the upgrade to 1.2?

Viewing 1 replies (of 1 total)
  • Yup, I’m having this problem as well. Driving me nuts too, errors occur in any bp version I’ve tried so far… don’t understand exactly how it’s happening either. I think it’s a server issue though as my local server didn’t have this problem (or at least not as often, can’t remember exactly)

    In previous versions (<1.2x), I got this problem which was resolved by changing all include() functions to include_once() within bp-loader.php.

    Now (WPMU 2.9.2 and BP 1.2.1), it seems that buddypress is being loaded from somewhere without it even being activated (I see the bp menu in wp-admin once bp is in my plugins folder). I think when trying it activate it it tries to load everything twice, and there comes the fatal error. I’d love some insight on this particular bit….

    The fatal error is blank for me too, but I can get it to start showing by changing error_reporting to the numerical E_ALL equivalent in my php.ini or httpd.config.

    I have had to hack BP to fix this issue again, the trick is:

    1. create a new file, e.g. bp-loader-fix.php
    2. move the contents of bp-loader.php over except the first comment block
    3. Make sure the new file has starting and ending <?php ?> tags, same with bp-loader.php
    4. in bp-loader.php, add the following as the last (and now only) php statement require_once('bp-loader-fix.php')

    That should prevent the redeclaration from happening.

    Can anyone offer insight on this? I’m on a CentOS PLESK environment, I wonder if it’s to do with that?

Viewing 1 replies (of 1 total)
  • The topic ‘"Plugin could not be activated because it triggered a fatal error"’ is closed to new replies.
Skip to toolbar