Skip to:

Problems with .htaccess

  • well, i started testing buddypress on my localhost (XAMP) and everything works great. Then i made an installation on my VServer and now i have problems with .htaccess.

    If i delete .htaccess the site comes up, but every link is 404.
    If i change Permalinkstructure and create a .htaccess i get an 403


    You don’t have permission to access / on this server.
    Apache/2.2.3 (Debian) mod_python/3.2.10 Python/2.4.4 PHP/5.2.0-8+etch16 mod_ssl/2.2.3 OpenSSL/0.9.8c Server at Port 80

    anybody an idea how to fix it?
    thanks in advance

Viewing 4 replies - 1 through 4 (of 4 total)

  • Bowe


    Create a new file in your root folder called .htaccess and put the following code in it (assuming you’re using a single WP install, not MultiSite)

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]


    Save the file and make sure it can be read by the server (chmod 644 I think). That should do the track if you have set up your permalinks properly (/category/postname in my case)

    thank you Bowe.
    but it didn’t fix my Problem. Only an empty .htaccess works without a permission-error. Well, is it possible to change the linkstructure for buddypress? for example index.php/activity/ instead of /activity/ ?

    sorry… i forgot.
    The error also exists in case i deactivate buddypress und change to wp default theme.

    ok, i hope it solved my problem permanently…
    I check in confixx my domain settings… mod_rewite was checked, but in my web.1.conf it wasn’t loaded, so i put the line:
    `LoadModule rewrite_module modules/` at the end of the document and restarted apache. Now it works…

    During restart i get the warning, that mod_rewrite can’t loaded twice… but, OK, it works…

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problems with .htaccess’ is closed to new replies.
Skip to toolbar