Skip to:
Content
Pages
Categories
Search
Top
Bottom

Random code at top of BP pages


  • scifigirl128
    Participant

    @scifigirl128

    I’m not sure which version this started happening with, but in the last I want to say month or so, there’s a random string of jquery at the top of all of the Buddypress pages on my website:

    https://girlinbluemusic.com/wp-content/uploads/2022/08/jquery.jpg

    I have confirmed that this still happens with the 2021, 2020, and 2017 themes, and it only seems to happen with the Buddypress plugin alone.

    Anyone have any idea how to get rid of this issue? I’ve also had some other recaptcha issues with my site, and I’m not sure if it’s related to this or to another plugin, but one thing at a time.

Viewing 5 replies - 1 through 5 (of 5 total)

  • scifigirl128
    Participant

    @scifigirl128

    Update regarding the random jquery: appears to be a plugin conflict from Booster for Woocommerce. I’ve reached out to them and hope they will respond soon


    michaelabf
    Participant

    @michaelabf

    Thanks for your update, even though I don’t have a similar issue on my site, it’s good to know other’s troubleshooting methods.

    What did you do to identify the cause? Disable everything and then re-enable plugins one by one til the issue reappeared?


    scifigirl128
    Participant

    @scifigirl128

    That’s what I started with: disabling plugins one by one, but that didn’t show any issues. I noticed the code was only appearing on Buddypress pages, so then I kept Buddypress active and one-by-one activated, checked, and then deactivated each plugin until the code reappeared.

    It takes a super long time, but it’s really the only way to really find issues like this (that I know of).

    I also use the Health and Troubleshooting plugin to do this, so the site doesn’t appear any different to anyone non-admins. That means people can keep using the site (I have courses with Learndash, so this is a big one!) while troubleshooting


    michaelabf
    Participant

    @michaelabf

    Great, I will look into using the Troubleshooting plugin, sounds very helpful.
    I have an issue currently on my site: can’t edit or create new profile fields in wp-admin > users > profile fields. This issue crept in at some point over the last year, and because its kinda “invisible” then its difficult to link it to any of the dozens of plugins & code snippets active on my site.

    I keep meaning to simply put the site in maintenance mode and start testing …gotta bite the bullet sooner or later I suppose.


    scifigirl128
    Participant

    @scifigirl128

    Glad I could help! And hm yeah I’m not knowledgeable enough to think of what might be causing that issue. But yeah just biting the bullet is really the best course of action most of the time.

    It’s very time-consuming though, and I totally feel your pain.

    Best of luck to you!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
Skip to toolbar