Skip to:
Content
Pages
Categories
Search
Top
Bottom

RC-1: no widgets?

  • Profile photo of Sgrunt
    Sgrunt
    Participant

    @sgrunt

    Hi guys please help me cause i’m into a very big problem.

    This morning i’ve installed the RC-1, and all was fine, bp was running smart.

    Then, i’ve entered the admin panel and i’ve seen that current widgets were…empty.

    They were all working on the site, but in the admin panel it resulted that there were not widget for left, center, or right column.

    And so, i’ve manually reactivated all the widgets, but now my bp show no widget: http://wikiroma.it/index.php , “please log in and add widgets to this column”. But they are already added!

Viewing 25 replies - 1 through 25 (of 28 total)
  • Profile photo of Sgrunt
    Sgrunt
    Participant

    @sgrunt

    the only widget that appears in my bp home is the “text” widget, but all the bp-related widgets: site-activity, members, groups, who’s online, do not show at all. All the rest of the bp works well: the problem is it only with the homepage widgets.

    Profile photo of Sgrunt
    Sgrunt
    Participant

    @sgrunt

    i’ve reuploaded the whole rc1 combo but nothing happens…and i’ve opened an assistance ticket too. Sorry to be boring, but the website is online and you know that it’s a pain. Thank you!

    I’ve the same problem… but.. not in english! maybe, for the time being, you can set your translation back to english. If I find a solution I will put it here.

    Profile photo of Sgrunt
    Sgrunt
    Participant

    @sgrunt

    hi roomer: do you think that the language is the cause of this bug? do you mean the wpmu language or the bp language?

    Profile photo of Sgrunt
    Sgrunt
    Participant

    @sgrunt

    yes you are in right!!! changing the wpmu settings to english it works! But this is still a pain, cause my users speak italian and not english…

    Profile photo of Arturo
    Arturo
    Participant

    @arturo84

    i’ve posted a message but i don’t view it…

    probably akismet block the url of bp italy site…

    Profile photo of Arturo
    Arturo
    Participant

    @arturo84

    ok ok my fault! ;)

    there are an error with localization in Italian, i’m working now on it to resolve, sorry for this.

    @sgrunt in the next hour go on BuddyPress Italy site and download the new version.

    Profile photo of Sgrunt
    Sgrunt
    Participant

    @sgrunt

    thanx Arturo, i hope we can solve this, and thanx for localization too!

    Profile photo of Sgrunt
    Sgrunt
    Participant

    @sgrunt

    Arturo i’m visiting buddypress ita, but i’ve not found any updated file, could you write something when it will be available for download? tnx!

    Profile photo of Arturo
    Arturo
    Participant

    @arturo84

    i’ve re-translated the RC-1 but the widgets don’t works… and i don’t know why. Andy any suggestion about this?

    sgrunt download the localization file and try, tell me if it works with you. thanks…

    Profile photo of m@rk
    m@rk
    Participant

    @mrk-1

    Sadly, i must confirm this issue with a german BP RC1, too … :-(

    Exactly the same problem as sgrunt declared.

    The only workaround to handle/ display widgets again seems to be deleting the wp-content/mu-plugins/bp-languages/buddypress-de_DE.mo (or what language ever).

    Praying for this issue being solved soon, since I had planed to launch my BP-Site “officially” this weekend …

    Profile photo of Arturo
    Arturo
    Participant

    @arturo84

    thanks mark, it’s right, this is the problem with the localization file.

    so we waiting Andy for a solution…

    Profile photo of Kazama
    Kazama
    Participant

    @kazama

    I got the same problem with thai language. I fixed it by “no translation for widget text” until this problem is fixed

    Profile photo of m@rk
    m@rk
    Participant

    @mrk-1

    arturo84, thanks for your quick reply. Feedback becalms in first…

    So: Andy Andy Andy (we believe in you) ;-)

    P.S.: i announced this issue in the german BuddyPress forum.

    Profile photo of Arturo
    Arturo
    Participant

    @arturo84

    u’re welcome mark, i’ve announced this in the buddypress-it.it site (italian) if the german team have a solution, please share it! ;)

    Profile photo of MartinNr5
    MartinNr5
    Participant

    @martinnr5

    Hi all.

    I had an issue with widgets when I first translated BP to Swedish.

    Try this: after you upload your translation file go into the admin panel and remove all widgets from the site.

    After this, re-add them the same way as they were before.

    Andy mentioned that WordPress registers widgets in a “wierd” way that translation can screw up.

    Profile photo of Arturo
    Arturo
    Participant

    @arturo84

    hi martin, i’ve removed, saved, re-added, and re-saved, but the widgets don’t appear.

    Profile photo of MartinNr5
    MartinNr5
    Participant

    @martinnr5

    Ok, then I don’t know what could cause this.

    I’ll see how my site reacts when I upload the new translation some time tomorrow.

    The strange thing is that the “add” button on the widgets is still in english… where o where is that hardcoded?

    Profile photo of Arturo
    Arturo
    Participant

    @arturo84

    nope roomer in my demo site i’ve “add” translated right… we waiting Andy for a solution…

    Profile photo of Sgrunt
    Sgrunt
    Participant

    @sgrunt

    i re-up this thread, cause i see that all the non-english buddypressers are blocked from this issue. Sorry to be boring Andy, and really thanks for you great work with bp!

    Profile photo of Michael Berra
    Michael Berra
    Participant

    @miguael

    I guess there were some localization changes anyway – since RC-1 the translations are back to “bad” (as far as it concerns german).

    About the widgets: It seems that it only affects BP-Widgets?!

    Profile photo of Sgrunt
    Sgrunt
    Participant

    @sgrunt

    yes, only bp widgets are affected

    Profile photo of Arturo
    Arturo
    Participant

    @arturo84

    i’ve another problem, if localization is active i don’t receive email from bp, like notices, plus widgets problem, if i disable localization the email works and widgets too…

    Profile photo of Michael Berra
    Michael Berra
    Participant

    @miguael

    I believe, that with a localization active (in my case german) the RSS-Feed per example for sitewide-activity doesn’t work (now, since I deinstalled the translation, it works surprisingly :-))

Viewing 25 replies - 1 through 25 (of 28 total)
  • The topic ‘RC-1: no widgets?’ is closed to new replies.