Skip to:

[Resolved] Can’t Install Sitewide Forum

  • coreymcollins


    Running: WP 3.2.1 on a subdomain of my main site. It’s a fresh install of WP and BuddyPress (1.5). The only other plugins installed are bbPress (2.0) and the Buddy Press Template Pack (1.2), both installed through prompts in the BuddyPress setup/options/notifications. Using the default BuddyPress theme. Not running any errors. Hosting on Dreamhost.

    Now that that’s out of the way, here’s my issue: I can’t install site-wide forums. BuddyPress claims to be able to offer site-wide forums without being group-specific. However, when I install site-wide forums, nothing on my site changes. The “Forums” link doesn’t appear, and if I navigate to /forums, there’s nothing available.

    If I activate Group Forums, I get the “Forums” link – but then I can only post to a specific group. If I deactivate Group Forums, the “Forums” link disappears.

    One thing I noticed is that in the bbPress settings, the “forums base” is set at “forums”, which then gives a message of “Possible BuddyPress conflict: Forums page”. This is how it is with a fresh install and without me changing any options – a conflict right away.

    I’ve tried uninstalling all of the plugins and deleting them, then doing a fresh install. I hoped it would run through the step-by-step BuddyPress settings so I could start totally brand new, but no luck. I went into phpMyAdmin and deleted the tables for BuddyPress, then tried installing again hoping that a totally fresh start would help – again, no luck.

    I tried changing the permalink of the “Forums” page and the “forums base” name in bbPress, but even having completely distinct names didn’t help at all.

    I’d really love to use this, as it has all of the features for a site I am currently working on. I just can’t get the forums to work at all.

Viewing 5 replies - 1 through 5 (of 5 total)

  • echoman


    LiIttle something i learned as a newb.
    Activate your forum next thing you’ll want to do is then go to your settings you’ll see forums on the bottom

    You’ll see archive slug and Single Slugs rename in the forum base and then in the forum slug below aswell. Because forum actually conflicts with the sitewide forum. let’s say name your sitewide forum bulletin board or support. The group forum natively is the forum on the header menu. Which you can later rename..

    Now you want to make a topic go to topic in the forums. Click you’ll see “all forums” and “new forum”
    I would click new forums, here you name a topic of interest. let’s say general discussion name your topic and below give a basic Description(optional).

    Now you want to save it you’ll then see a link look at the link copy it. but only copy

    Next thing you’ll need to do which is the final step. Go to the appearance section. You’ll see menu which is you site navigation menu. You’ll have a few things you have to do here.

    First make sure you make a custom menu or which now the main theme allows you to or you can make a custom menu name.

    look at the section on the top left corner a drop-down you click whichever theme is named or you select as your menu save .
    Now go down to custom links remember that link you copied earlier( paste it in there and name it click add to menu.

    Now you have a list you can now rearrange move or even create a drop-down menu on. What i did have activity /members /group and with forums i renamed that “group forum directory” moved that slightly to the right which creates a Drop-down, then the site wide forum which i named support or whatever you want to call it. Now save. DONE!!

    Go to your site homepage and everything should be there. Best of luck!! :)



    Holy crap, you are a gem. This worked perfectly! I had tried changing the archive and single names before, but nothing was changing. Adding the custom menu item and linking to the new archive name did the trick.

    Thanks so much!



    You’re welcome glad i could help, lol. :)

    Good work, guys — I’ve edited the topic so people see that there’s an answer in the thread :)

    Hello ppl,

    I have tried and followed the instructions as given above but my forum turns blanc …
    I was wondering if there is any techy around thats willing to help give it shot.

    The scenario is, I am trying to import a bbPress forum into buddypress.

    Thanks in advance.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Can’t Install Sitewide Forum’ is closed to new replies.
Skip to toolbar