Skip to:

Send-to autocompletion is broken

  • open flips



    I use buddypress with “Friends” functionality disabled. When I go to send a message and start to write anything in the autocompleted send-to field, Buddypress shows up some html stuff taken from posts and pages…

    I did not manage to take a screenshot while the autocompleted list is displayed but if you tell me how, I could do so.

    Thanks for fixing.

Viewing 10 replies - 1 through 10 (of 10 total)

  • open flips


    Hi, did you have time to have a look at that bug ?

    I also have the same problem. Not just with my regular site, to which I’ve done a ton of tweaking, but also on a fairly fresh install on a different domain. What happens is that I click on “send private message” and everything comes up fine, an email with name of the person I’m about to email, plus a text-entry box to the right of the name. If I try to type into that field, the first thing that happens is that my header image reverts to the original blue of the default buddypress install… and then if I click “tab”, the following html comes up in that field I just tabbed out of: “”. Odd.

    This installation of WordPress only uses the BuddyPress plugin. No other. It’s a relatively clean install, again, with 1 plugin. My main site, however, also exhibits this problem.

    thanks in advance for the help on this.

    here’s that html again. just a basic Html Head: ”

    one more time “

    open flips


    Can someone help us on this ?

    I can’t recreate this issue on a clean 1.2.6 / 3.01.

    If you do think this is an issue with BP and there are no custom themes or plugins running that may conflict with JS then you will probably need to create a ticket in Trac so that one of the core devs can look into it.

    open flips


    Thanks @hnla,

    I have just installed a clean 1.2.6 / 3.01 and created some users.

    When I start to type in sent-to field, nothing appears… Could you tell us how it exactly works for you ?

    Boone Gorges


    Just to clarify: All people experiencing this problem are using the default theme, and have the friends component disabled, right? By design, the autocomplete does not work with Friends turned off (a limitation which was recently fixed in the trunk), but it definitely shouldn’t be doing what some have described here.

    Ditto here, I’m not using the default theme, and I don’t have the friends component disabled..



    I am using default Theme and Friends Feature on, had the same Problem but fixed it.
    Here is how i fixed it:

    I fixed it.

    It was an Error with the settings.urlLookup function.
    For Example:


    was giving me:

    But that was not The URL to the wp-load.php,
    so i fixed the Code:


    Now it is working Great, for Explaining or Helping with the Fix contact me.

    Best Regards,
    Steffen Rogge

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Send-to autocompletion is broken’ is closed to new replies.
Skip to toolbar