Skip to:

Setting Activity as BP home page.

  • Hi,

    I know how to set the activity stream as the home page of buddypress. But i have my buddypress on a secondary blog in multisite and when I set the activity stream as the homepage rather than the recent posts page it gives me a 404 error.

    Does it have to do with it being a secondary blog on multisite?

    Is there another way for me to set activity stream as homepage?


Viewing 4 replies - 1 through 4 (of 4 total)

  • r-a-y


    Depending on your BP version, have you tried upgrading BuddyPress?

    Also try to resave your permalink settings:

    I have activity stream set as frontpage on a secondary blog on my test install.
    Works fine.

    my BP version is 1.2.6. I’m also using a custom permalink structure…./%post_id%/%postname%/

    Do you think the custom structure may be affecting it? Should I use one of the common settings instead?

    Also I’m using a non BP theme that I’ve used the template pack for and converted css etc.




    Custom permalink structure shouldn’t matter, but have you tried resaving the permalink settings?
    Also try disabling any plugins that might interfere with this. Including redirect and caching plugins.

    As a last resort, you can always create a page template copying exactly what is in /buddypress/bp-themes/bp-default/activity/index.php and setting that as the front page…

    Yes I have tried resaving the permalink settings. Didn’t work.

    I’ve also looking at my plugins and I don’t have any redirect or caching plugins that may possibly affect this. I guess my next step is to create a new page like you said.

    Thanks for your help ray. If you think of anything else let me know.

    Thanks again.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Setting Activity as BP home page.’ is closed to new replies.
Skip to toolbar