Skip to:
Content
Pages
Categories
Search
Top
Bottom

The Notorious Unable to Register Problem RESOLVED BY LEAVING PORT # BLANK!

  • Wordpress 3.1.3
    Latest BP install
    WP Simple Community BuddyPress Theme
    Thank you guys for all the help thus far all of my issues have pretty much been resolved but this registration problem is a huge headache.
    When people create an account everything goes fine and it goes to the page that says an activation email will be sent but it never is. The registered user does show up in the admin panel under users but their registration is not active.
    I have tried changing themes, uninstalling and reinstalling both BP and WP. I have deactivated every plug in and tried every compatible SMTP plug in. The SMTP plug in creates an error that says the SMTP server is not responding when a test email is sent. So far nothing has worked.
    Does anyone have another solution to try or has anyone using the same installs had any success and can share how to fix it?
    Is it possible to deactivate the themes log in and registration and use a plug in instead? I tried to do this but didn’t really know what I was doing.
    If it helps my site is verbradio.com

    As always your help is appreciated.

Viewing 4 replies - 1 through 4 (of 4 total)

  • dude
    Member

    @pinhit

    i had tons of trouble with this.

    Don’t know if you tried these methods but they worked for me..

    I used two plugins:

    Mail From and WP-Mail-SMTP

    with mail from I had to create a myname@mydomain in the email section of cpanel because my site was stuck in default ‘noreply@mydomain.com’

    It kinda splits your email send outs as: username @example.com
    I chose: eMail Address admin@mydomain.co.uk as the Current address WordPress is sending mail from

    With the other plugin I noticed one major edit solved the whole issue for me in terms of my site sending out the registry email verifications.

    First I chose to send out the emails with my newly created email address (made in cpanel)
    then I checked the: Send all WordPress emails via SMTP box
    then I chose: SMTP Host = localhost
    then this was the was crunch that seemed to make it work..I changed the default SMPT port from 25 to 26 and it worked !
    I also chose: Authentication No: Do not use SMTP authentication.
    sent a ‘test’ email out to a test account on my site and all was ok.

    I don’t know if this will work for you..but all I can say is it worked for me so no harm in trying.

    This issue took me 3 weeks to solve !!

    Thanks Kenny. I forgot to also mention in my post that I am using godaddy free hosting which doesn’t come with SMTP mail and so I am trying to use Googles SMTP server. I tried both of the plugins mentioned above but I don’t think I tried them together so I will go back and do that. Three weeks WOW! I think I might be headed there though and I’m really anxious to launch the site.


    dude
    Member

    @pinhit

    your welcome,

    yes I’m running both plugins together as I found that it won’t work if one of them is not present.

    hope it sorts things out and good luck with the launch !

    So I finally licked the email issue!
    There were a couple of things going on:
    1. If you use Godaddy you have to send mail through their mai server. I thought SMTP relay wasn’t allowed on free hosting but it is.
    2. I used the WP-Mail-SMTP make sure that you leave the PORT NUMBER BLANK! That solved the problem! Once again DO NOT enter a PORT NUMBER!
    3. Also using the Mail From plug-in not sure if that has a bearing but threw it in for good measure.
    Don’t know if leaving the port blank will work for other hosts but it’s worth a try!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘The Notorious Unable to Register Problem RESOLVED BY LEAVING PORT # BLANK!’ is closed to new replies.
Skip to toolbar