Skip to:
Content
Pages
Categories
Search
Top
Bottom

The page you were looking for was not found.


  • Will White
    Participant

    @willpcg

    I’ve recently re-installed WMU 2.7.1 and got it working correctly. Then I downloaded the latest BP (1.0) and activated it. I then moved the bp-themes to the wp-content directory and bphome to the themes directory.

    I’ve activated the default theme and haven’t edited a single line of code yet.

    When I go to the site, I can get to places like Members, Group, Blogs etc – but when I load up a profile (with all the links to things like “The Wire” “Friends” etc) all the links load pages in the BP theme that say “Sorry, that page could not be found” and “The page you were looking for was not found.”

    Any thoughts on what could be causing this?

Viewing 25 replies - 1 through 25 (of 39 total)

  • John James Jacoby
    Keymaster

    @johnjamesjacoby

    You installed BuddyPress in http://www.example.com/members ?


    TheEasyButton
    Participant

    @theeasybutton

    Make sure that you moved the themes, not copied them over. Having them in 2 places can make things go silly.

    Also, you say that you activated the plugins and then moved your themes around. Go to the bp settings, use the profile theme selector, select the bp member’s theme and then save it. Don’t just save it if it’s already there. Use the pull down menu and choose it again & save it.

    This probably won’t fix the issue but it’s worth a shot. I know sometimes my installations get a little wonky with profiles if I do it out of order.


    Will White
    Participant

    @willpcg

    Thanks! I’ll give it a shot.


    Will White
    Participant

    @willpcg

    No Luck.

    I tried removing the duplicate files, then reactivating the theme.

    When I went to reactivate the theme the screen that pops up that should you the screenshot of the theme and has the “Activate This Theme” at the top right had this message:

    You do not have any BuddyPress themes installed.

    Please move “/wp-content/plugins/buddypress/bp-themes/” to “/wp-content/bp-themes” and refresh this page.

    However, I’m staring at my ftp screen and its already there!


    TheEasyButton
    Participant

    @theeasybutton

    The page that gives you the popup activation is for the home theme. The home theme should be in

    wp-content >> themes >> bphome

    Kind’ve funny that it’s telling you to put it into the wrong place. Unless I’m totally misunderstanding what you’re saying.

    And the members theme should be

    wp-content >> bp-themes >> bpmember


    Will White
    Participant

    @willpcg

    wp-content >> themes >> bphome

    wp-content >> bp-themes >> bpmember

    Thats how I’ve got my files set up – so if thats correct then things should be working appropriately. I can’t figure out why the things like “edit profile” etc don’t seem to work.


    Will White
    Participant

    @willpcg

    You installed BuddyPress in http://www.example.com/members ?

    That was just an example of the structure that the links seem to follow – not the actual url.

    The actual url is nacdb.com/members


    TheEasyButton
    Participant

    @theeasybutton

    I swear you keep editing your initial post – Quit it. LMAO

    I see what you’re saying. All of your links have an extra directory in them.

    members/admin is what you want

    member/members/admin is what you’re getting.

    Is your buddypress stuff in

    wp-content >> plugins >> buddypress


    TheEasyButton
    Participant

    @theeasybutton

    Sorry to double post, but how is everything set up?

    Does your root have your wp-content folder or is is more like:

    members/wp-content ?


    Will White
    Participant

    @willpcg

    To answer both questions the setup/directory listing for buddypress is

    nacdb.com/members/wp-content/plugins/buddypress/

    nacdb.com/members/wp-content/themes/bphome/

    nacdb.com/members/wp-content/bp-themes/bpmember/

    members/ contains all of WMU – its not in the root directory.


    TheEasyButton
    Participant

    @theeasybutton

    What’s weird to me is that your home page (nacdb.com/members) has the profile index. It’s almost as though you’ve got bpmember in the wp-content/themes directory.

    Yep – I’m at a loss. Hopefully JJJ or one of the other brilliant minds here can sort it out for you.


    Will White
    Participant

    @willpcg

    Pages that seem to work

    members/

    members/blog

    members/members

    members/groups

    members/blogs

    Pages that don’t work

    members/activity

    members/wire

    members/friends

    members/admin

    members/admin/profile

    members/admin/messages

    members/admin/settings

    members/admin/groups

    members/members/admin/profile/change-avatar

    members/members/admin/activity/just-me

    members/members/admin/activity/my-friends

    (and the rest of the links at the top left on the toolbar dropdowns)


    Will White
    Participant

    @willpcg

    I just removed BP from the WMU completely, then reinstalled it following the directions at https://codex.buddypress.org/getting-started/installing-buddypress/ to the T and the same problem is still happening.


    Anonymous
    Inactive

    Mine is doing something similar, I think.

    WPMU was installed first… worked fine, tested some blogs and users.

    Installed BP via the Plugins installer… activated it sitewide, no errors.

    Moved (not copied) the bp-themes folder …

    Put BP Home theme into themes directory & activated it for the home blog.

    Results: none of the links in the My Account dropdown work — all point to

    http://blogsite.ca/members/blogname/…

    … when our WPMU is set up to have the blog name at the beginning, like:

    http://blogname.blogsite.ca

    Modifying the My Account addresses (manually, for testing) to this doesn’t work, either:

    http://blogname.blogsite.ca/members/blogname/… OR

    http://blogname.blogsite.ca/members/…

    That, and the homepage for our site no longer shows a blog page, but a login page — and it doesn’t accept my login & password combo (which worked just fine to get into the Dashboard for my blog).


    Will White
    Participant

    @willpcg

    I think I’ve narrowed down the problem. The installation isn’t recognizing the fact that bp-themes is in the wp-content directory.

    Even though the two options for Member and Skeleton themes are available through the buddypress settings panel, whenever I try to load the BP theme itself after activating it the large screenshot that comes up just says “You do not have any BuddyPress themes installed.

    Please move “/wp-content/plugins/buddypress/bp-themes/” to “/wp-content/bp-themes” and refresh this page. “

    However I’ve verified, and re-verified, and re-verified again that bp-themes is, in fact, in the wp-content folder along with themes plugins mu-plugins etc.

    Anyone know what could be causing this?


    Will White
    Participant

    @willpcg

    I’ve tried switching to the skeleton theme and back, as mention in another post but still haven’t had any success.


    TheEasyButton
    Participant

    @theeasybutton

    I swear that you\’re talking about 2 separate things.

    When activating the home theme, you will first use \”Themes\” to enable it. Then, you go to Appearance, click the theme and you get the big popup where you click activate.

    When activating the profile (member) theme, there is no screen shot. Only a pull down menu.

    So your statement of \”whenever I try to load the BP theme itself after activating it the large screenshot that comes up just says \”You do not have any BuddyPress themes installed.\” seriously confuses me.

    That error should only be coming up on the profile page. i.e. nacdb.com/members/members/admin

    Also, could you enable registration of username & blogs so that anyone attempting to help can sign up for an account if need be.


    Jeff Sayre
    Participant

    @jeffsayre

    WillPCG-

    Okay a few additional questions:

    1. Are you logging into WPMU’s backend as the site administrator, and not just as a user with administrator privileges?
    2. You’ve mentioned 404 erros in your other thread. Are there any errors in your log files? If so, what are they?
    3. Did you go to “BuddyPress > General Settings”, re-select the member theme, and then hit save? Do this even if the theme is already selected.


    Will White
    Participant

    @willpcg

    TheEasyButton

    Sorry for the confusion! Let me try to re-explain the process I followed.

    I’ve loaded the buddypress addon and moved all the folders to their appropriate spot.

    Then, I enabled the “BuddyPress Default Home Theme” under the Site Admin dropdown.

    I clicked through to the Appearance drop-down, and when I go to activate the theme, the screenshot loads with the error message regarding the misplacement of bp-themes directory. So I double checked the placement of the folder, and verified they are in the correct spot – despite what the error message says.

    I activated the file anyway, and then click the BuddyPress drop down and changed the “Member theme” to Skeleton, saved it, then switched it back, and saved it again.

    I activated user registration so you can sign up now as well, hopefully that will help.

    Jeff Sayre

    1. Yes – at the top of my screen it says “You’re logged in as a site administrator.” I’ve been going in through nacdb.com/members/wp-admin/ with the admin login and its password.

    2. I reset the error log, visited the buddypress setup, and copied the errors it produced at the bottom of this post. I seem to get the same one over and over.

    3. I’ve reselected the member theme (even switched it to the skeleton one and back) without any success.

    PHP Warning: Unknown(): open(/var/php_sessions/sess_b0fd681715d71fc2290936406bc797ba, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

    PHP Warning: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/php_sessions) in Unknown on line 0

    PHP Warning: Unknown(): open(/var/php_sessions/sess_b0fd681715d71fc2290936406bc797ba, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

    PHP Warning: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/php_sessions) in Unknown on line 0

    Thanks for all the help guys!


    Anonymous
    Inactive

    OK, mine does sound different from WillPCG…

    For example, I can’t go to any URL with /members/ in it… and I get no error messages with regard to the themes, just the 404 errors when I go to most of the links in the Options bar.


    gladsteins
    Participant

    @gladsteins

    I am having same issue

    “Please move the default BuddyPress themes to their correct location (move D:\apache2triad\htdocs\wordpress/wp-content/plugins/buddypress/bp-themes/ to D:\apache2triad\htdocs\wordpress/wp-content/bp-themes/) and reload this page.”

    See all the folders in the correct spots

    Do NOT have option to activate Buddy Theme in Admin themes

    Nor do I see a /members dir in WP structure


    Jeff Sayre
    Participant

    @jeffsayre

    WillPCG-

    Okay, thanks for the updated information. From those error messages, it appears that PHP is having trouble saving session information. This will cause big issues. However, this is not a BuddyPress nor WordPress-specific issue. This is an issue with your web server.

    I suggest that you contact your web hosting firm and ask them to help you.


    gladsteins
    Participant

    @gladsteins

    from what I understand the session information would account for the members, recent activity etc not working but not the missing template – am I missing something – only issue with buddy press application

    BTW – looking to use this in K-12 setting -we have a number of blogs setup but want to extend to students and add social networking


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Gladsteins, there won’t be a /members directory in your structure.

    Within your /bp-themes/ directory are there themes in there? Namely bpmember? If your /bp-themes/ directory is empty, then nothing will show up in your settings screen.

    Let me ask all of you a question. On your root blog, the main blog of your site, what do you all have your WordPress MU Permalinks set to? Admin->Settings->Permalinks


    Anonymous
    Inactive

    Mine appears to be set to Day and name – I switched it to ‘Default’, but it didn’t change anything related to the Option Bar.

Viewing 25 replies - 1 through 25 (of 39 total)
  • The topic ‘The page you were looking for was not found.’ is closed to new replies.
Skip to toolbar