Skip to:
Content
Pages
Categories
Search
Top
Bottom

Theme Incompatibility Issue


  • millermc38
    Participant

    @millermc38

    Long-time lurker on forums of every kind, I think this is my first time posting ever in my time on the internet, so you can tell that I’ve really run out of options :)! To be clear, the most important fact is that I found out that buddypress works with the twenty seventeen theme, but not mine (I did a preview with that theme, and that was when I knew I was in trouble).

    As you can see, I added a top menu for people to register at: http://www.toledonaturalist.org/forums/

    But there is no content on the page. I’ve thought of all sorts of fixes, the most promising of which is either making the twenty seventeen theme just for the forum pages (which is messy) or switching themes entirely. However, I am in grad school and pretty much every hour of my day is spoken for, so I don’t have time to switch themes. Does anyone have any recommendations on how I can make this work for my website? We are a nonprofit, and really looking forward to building an online community.

    Also, I’ve only set up the registration page (i.e., linked it to buddypress in the buddypress pages tab), so the login page definitely won’t work if you click on that.

    1. Which version of WordPress are you running?
    5.1
    2. Did you install WordPress as a directory or subdomain install?
    Directly
    3. If a directory install, is it in root or in a subdirectory?
    Not sure!
    4. Did you upgrade from a previous version of WordPress? If so, from which version?
    Not sure!
    5. Was WordPress functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting.
    No, it has never worked with my website.
    6. Which version of BP are you running?
    Version 4.2.0
    7. Did you upgraded from a previous version of BP? If so, from which version?
    No
    8. Do you have any plugins other than BuddyPress installed and activated? If so, which ones?
    Yes, but I’ve deactivated them all and it still does not work.
    9. Are you using a standard WordPress theme or customized theme?
    Standard
    10. Which theme do you use ?
    Gaea: https://themeforest.net/item/gaea-environmental-wordpress-theme/9383580
    11. Have you modified the core files in any way?
    No
    12. Do you have any custom functions in bp-custom.php?
    No
    13. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?
    Version 2.5.14
    14. Please provide a list of any errors in your server’s log files.
    Sorry, I’m not at this level!
    15. Which company provides your hosting?
    Host Gator
    16. Is your server running Windows, or if Linux; Apache, nginx or something else?
    Not sure!
    17. Which BP Theme are you using?
    Basic?
    18. Have you overloaded any BuddyPress template files.
    No
    19. Any other site customisations that might have a bearing on the issue?
    No

Viewing 3 replies - 1 through 3 (of 3 total)

  • Venutius
    Moderator

    @venutius

    This is probably down to your theme or a plugin overloading the registration page.


    millermc38
    Participant

    @millermc38

    Okay thanks. I did the usual check for plugins, and it appears to be the theme itself. I searched for tools to intercept whatever mechanism within the theme is causing these, but came up dry. I’m not a developer, so is there a way to tackle this issue without coding? A backup plan could be that I talk to the developers of the theme and see if they can fix it…let me know what you think!


    Venutius
    Moderator

    @venutius

    Yep you need to ask the theme author if they can fix it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Skip to toolbar