Skip to:

Unable To Save Profile Settings

  • ma3ry


    I am running a membership WP v4.6.1 multisite at,, and My registration uses Simple Membership but my profile fields use BuddyPress v2.6.2 with BP Xprofile Custom Fields Type.

    I have just updated to PHP v5.6 but was also having problems with PHP v5.3.

    I started having a problem saving changes to profiles, specifically changing the age (DOB) field. Now I can’t save profiles at all. I get notification of:

    “Please make sure you fill in all required fields in this profile field group before saving.”

    I first tried removing the age field, which is when I found out that I can’t save any settings at all.

    I tried changing all profile fields to “not required”. Still no success.

    I have deactivated network plugins and tried activating site specific plugins.

    I have tried deactivating ALL plugins except those absolutely required.

    I have tried changing theme to twenty-sixteen.

    I don’t know what to try next. Would appreciate any suggestions. Thank you!

Viewing 1 replies (of 1 total)

  • danbp


    Hi @ma3ry,

    the issue comes probably from the membership plugin who conflicts with BP registration.

    In brief, what ever this plugin does(or not), when BP is activated, you have on registration process the WP login routine (username, email, password) and the little mandatory Name field coming from BP.

    That’s all.
    What probably happen, is that you don’t have this Name field on Single Membership registering…
    Because of this, BP doesn’t know about the user existence and can’t fire the additionnal xprofile fields.

    That the first diagnostic.
    A second one may be more complex, as it is related to the fact you changed the php version and using WP 4.6.x

    You certainly made a big DB dump before that change. And also a new WP install – or at least, a WP update. If you made just a WP upgrade, it would be ok to a certain point.

    If you started a new install after the php change, the problem can be in the old datas you injected to the new DB. But no panic, it’s only an hypothese at the moment.

    So it would be great you give details about this and if possible your server configuration.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.
Skip to toolbar