Skip to:

Upgrade, then fresh install, generates error 500

  • rolfe


    I looked at a few recent posts and searched for keywords but didn’t recognize the problem I’m having.

    I had Version, which worked well. Upgrading to 1.2.3 caused trouble. (Clicking any of the tabs on the front page wouldn’t work. I don’t remember the exact symptoms)

    After downgrading, the trouble went away.

    Still wanting to upgrade, I deleted everything: files, directories, databases, database users.

    After making a fresh install of Version 1.2.3, the trouble came back. Clicking The Activity, Members, Groups, Blogs, About tabs generates the following error:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, /removedemailaddress/ and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8l DAV/2 mod_auth_passthrough/2.1 FrontPage/ Server at Port 80

    Would appreciate any suggestions. Thanks, rolfedh

    (Using bluehost for hosting)

Viewing 8 replies - 1 through 8 (of 8 total)

  • rolfe


    Also, I was using SimpleScripts to do the installations and uninstallation



    Just tried deactivating, uninstalling, reinstalling, reactivating the buddypress plug-in. That didn’t work. Same problem.

    Also, I have kept all the default settings, so I don’t think this is related to any configuration changes.





    Try doing the upgrade manually without SimpleScripts (if you are able to) and see if that fixes your problem.



    After trying several variations, I completed an WordPress MU installation.

    Here’s a tip for anyone else using cPanel, use “MySQL Databases” instead of “MySQL Database Wizard” to:

    1. Create a new database.

    2. Create a new user with ALL privileges.

    3. Add the user to the database.



    To recap:


    BlueHost hosting, WordPress MU + BuddyPress installed via SimpleScripts and automatic upgrades. Also had WordPress in a root directory.


    After upgrading to BuddyPress 1.2.3, clicking the tabs for Activity, Members, Groups, Blogs, About generated an Internal Server Error.


    Removed the WordPress installation from the root web directory.

    Deleted the directory containing the WordPress MU + BuddyPress.

    Deleted the previous databases.

    Create a database and database user.

    Manually install WordPress MU (WPMU)

    Manually install BuddyPress.


    If you have questions along the way, start with the links provided by the WPMU installation page (on your website) and search the WordPress MU and BuddyPress support forums. I also recommend the free ebook, Installing WordPress MU For Beginners, by Andrea Rennick, available at

    Use cPanel > MySQL Databases to create the database, create the user with ALL privileges, and assign the user to the database. Avoid using the “MySQL Database Wizard” tool. I got connection errors when I used the wizard.

    I have an open request to my web hosting provider, BlueHost, to enable wildcard subdomains for my domain. (I elected to have new blogs appear as subdomains.) You can avoid this hassle if you opt to create user blogs as subdirectories.



    BlueHost replied “Not at this time in the future it may be available but currently we do not allow any wildcards.”

    Another problem solved by installing WPMU+BP manually: Sending confirmation emails to new users. With the automated SimpleScripts installation, WPMU+BP couldn’t connect to the email server. I had to install the “Cimy Swift SMTP” plugin to overcome this problem. After installing WPMU+BP manually, WPMU+BP connected to the email server automatically without any problems and without any SMTP plugins.



    The trouble was a line in the .htaccess file that was not edited properly. For anyone else having this trouble (it has been fixed on the SimpleScripts end) the line that needs to be changed is:

    RewriteBase /wordpress-mu/


    RewriteBase /your-installation-directory/

    (replacing with your directory)


    RewriteBase /

    (if your installation is in the root of your domain eg. instead of

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Upgrade, then fresh install, generates error 500’ is closed to new replies.
Skip to toolbar