Skip to:
Content
Pages
Categories
Search
Top
Bottom

User and Group Content Disappeared on Site After Updating Buddypress 1.9.1

  • Avatar of brinkingyellows
    brinkingyellows
    Participant

    @brinkingyellows

    Hello,

    First, I’d like to say that I really have a ton of respect for you guys that continue to work and improve Buddypress. It’s a great accomplishment. Thank you.

    I had recently attempted to update my Buddypress 1.8.1 to 1.9.1. When the update was complete all Buddypress user and group activity, profile content and basically everything that appears in a page had disappeared. I even tested it on the Twenty Fourteen WP template and the content still did not show up.

    I quickly removed the 1.9.1 update and replaced back with the 1.8.1 version. I am using the latest version of WordPress 3.8. My site URL is http://www.freedomcgc.com.

    Here are some screen shots of the before and after of a user profile. One with Buddypress 1.8.1 and the other with all the content gone using Buddypress 1.9.1.

    FREEDOM site with Buddypress 1.8.1

    http://http.freedomcgc.com/wp-content/uploads/screenshots/ScreenShot2014-01-09_BP_181.png

    FREEDOM site with Buddypress 1.9.1

    http://http.freedomcgc.com/wp-content/uploads/screenshots/ScreenShot2014-01-09_BP_191.png

    Have any of you guys had the same problem? If so, could you give me some direction as to what it could so that I may make the adjustments? Any help and assistance would be tremendously appreciated.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    If you say you tried Twenty Fourteen and BuddyPress 1.9 is not working, then it’s possible there is a plugin conflict somewhere.

    This is probably related to this ticket:

    https://buddypress.trac.wordpress.org/ticket/5021

    Can you list the plugins you are using that affect page content? Anything that tries to inject or modify the page content.

    Avatar of brinkingyellows
    brinkingyellows
    Participant

    @brinkingyellows

    Hi @r-a-y. Here are the plugins I am currently using on the site.

    Network Activated:

    Advanced Responsive Video Embedder
    Anti-Splog
    Are You a Human
    bbPress
    bbPress – Report Content
    bbPress Enable TinyMCE Visual Tab
    bbpress Simple View Counts
    BP Profile Search
    BuddyPress Activity Plus – (I did deactivate this after the 1.9.1 update but nothing changed)
    BuddyPress Avatar Bubble
    BuddyPress Follow
    BuddyPress Group Calendar
    BuddyPress Groups Extras
    Buddypress Social
    BuddyPress Toolbar
    BuddyPress Twitter
    Buddypress Xprofile Custom Fields Type
    GD bbPress Toolbox
    Group Forum Crumbs
    rtMedia for WordPress, BuddyPress and bbPress
    User Activity
    WP User Avatar

    —-

    Single Site Actived

    Amazon Product In a Post Plugin
    BuddyMenu
    BuddyPress Notifications Widget
    Really simple Facebook Twitter share buttons

    That’s about all the plugins that I have active that play a heavy part in Buddypress or are loosely connected to it.

    Avatar of focallocal
    focallocal
    Participant

    @focallocal

    I have the same issue. i’m using Response 2.0 Theme by Cyberchimps and have the following plugins the same as brinkin:

    BuddyPress Follow
    bbPress – Report Content

    i deactivated them both but it didnt fix the problem

    Avatar of brinkingyellows
    brinkingyellows
    Participant

    @brinkingyellows

    No, ideas as it pertains to my issue based off of what plugins I am using?

    I just haven’t heard anything further regarding my post here.

    Avatar of brinkingyellows
    brinkingyellows
    Participant

    @brinkingyellows

    @focallocal I saw that your site is running 1.9.2 now. What was it that you did to get the update working?

    I tried to update to 1.9.2 and I am still getting the same result. No content on the User and Group pages. I was hoping that with the 1.9.2 version they may have fixed any sort of little issues that remove the pages of Buddypress altogether.

    Avatar of focallocal
    focallocal
    Participant

    @focallocal

    i had to switch themes to the significantly more restricted CyberChimps Free Theme and then restyle it to look like my old theme, it took weeks.

    here’s most of the code i added to my child theme to get it to look the same:

    article {
     border: 1px solid #d4d4d4;
    		}
    
    .widget-container {
      	 border: 1px solid #d4d4d4;
    		}
    
    .current-menu-ancestor.dropdown {
    background-color: #0777FF
    		}		
        
    
    #social {
    	float: right;
      padding-top: 5px;
     			}
      
    #logo {
        padding-top: 25px;
    			}
    
    #wp-admin-bar-cyberchimps {
    		display: none;
    		}
    
    .main-navigation .navbar-inner {
    	padding: 0px;
    	-webkit-border-radius: 1px;
    	border-radius: 1px;
    	}
    
    .navbar-inner {
    	padding: 0px!important;
    	min-height: 40px;
    	padding-right: 0px!important;
    	padding-left: 0px!important;
    	background-color: #fafafa !important;
    	background-image: -moz-linear-gradient(top, #ffffff, #f2f2f2)!important;
    	background-image: -webkit-gradient(linear, 0 0, 0 100%, from(#ffffff), to(#f2f2f2))!important;
    	background-image: -webkit-linear-gradient(top, #ffffff, #f2f2f2)!important;
    	background-image: -o-linear-gradient(top, #ffffff, #f2f2f2)!important;
    	background-image: linear-gradient(to bottom, #ffffff, #f2f2f2)!important;
    	background-repeat: repeat-x;
    	border: 1px solid #d4d4d4!important;
    	-webkit-border-radius: 4px;
    	-moz-border-radius: 4px;
    	border-radius: 4px;
    	filter: progid:DXImageTransform.Microsoft.gradient(startColorstr='#ffffffff', endColorstr='#fff2f2f2', GradientType=0)!important;
    	-webkit-box-shadow: 0 1px 4px rgba(0, 0, 0, 0.065);
    	-moz-box-shadow: 0 1px 4px rgba(0, 0, 0, 0.065);
    	box-shadow: 0 1px 4px rgba(0, 0, 0, 0.065);
    	}
    
    user agent stylesheetdiv {
    	display: block;
    	}
    
    .nav .active > a:focus {
    	color: #ffffff!important;
    	background-color: #0777FF;
    	}
    
    .navbar-inverse .nav .active > a, .navbar-inverse .nav .active > a:hover, .navbar-inverse .nav .active > a:focus {
        	background-color: #0777FF!important;
    	}
    
    .navbar-inverse .nav > li > a {
    	color: #696969;
    	font-size: 15px!important;
    	text-shadow: 0!important;
    }
    

    you’ll notice that nearly everything needs !important tags. i dont know why, but it seems you need these to override any code in the the cyberchimps free theme

    Avatar of brinkingyellows
    brinkingyellows
    Participant

    @brinkingyellows

    Thanks for the response, @focallocal. For some reason, that doesn’t seem to fix the situation in my case. I’m still looking for answers.

    Avatar of brinkingyellows
    brinkingyellows
    Participant

    @brinkingyellows

    Alright, finally after a couple of months of doing some serious investigating, it turns out that a plugin called Members Directory was causing the issue. After fully removing that plugin and then updating to this latest 1.9.2 version of Buddypress everything finally worked. It was the order of how I had to go about removing the plugin first then applying the update to Buddypress that was needed. Not sure why but I’m up and going now.

    Thanks for all those that attempted to help out and I’ll keep you posted if anything else pops up. Have a great weekend everyone!

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.