Skip to:

Warning & Fatal Error! Please Help

  • bob123451


    I have deactivated all my plugins, and just tried activating Buddypress, but I am still getting this error code again and again! I have deleted the Buddypress from my server and reinstalled it, but still the same problems. I can’t figure out how to fix this, if you could please help I would be thankful! Everything was running fine till I made the mistake of changing a setting on my wordpress theme in which it made my theme (website) private or public. I made it public so you could visit the front end of the website while logged out, but after doing that it wouldnt allow me to log in because it was saying it wasnt allowing registration at that time. So I had my hosting provide help me deactivate and change the plugins so I could log in. But after doing that everytime I try reactivating buddypress I get those errors!

    Thanks for you time, hope you can help me out!

    Warning: Creating default object from empty value in /home/dtente5/public_html/SocialNetwork/wp-content/plugins/buddypress/bp-xprofile/bp-xprofile-functions.php on line 258

    Fatal error: Call to undefined method stdClass::save() in /home/dtente5/public_html/SocialNetwork/wp-content/plugins/buddypress/bp-xprofile/bp-xprofile-functions.php on line 275

Viewing 3 replies - 1 through 3 (of 3 total)

  • r-a-y


    Are you using the WOffice theme and their Birthday extension?

    If so, see:



    Thanks for the reply Ray..

    Yes I am using the WOffice theme!

    I get this code under the Birthday plugin:

    Fatal error: Call to undefined function xprofile_get_field_data() in /home/dtente5/public_html/SocialNetwork/wp-content/themes/woffice/framework-customizations/extensions/woffice-birthdays/class-fw-extension-woffice-birthdays.php on line 31

    Any ideas?



    Figured it out!:)
    Went into the File Manager on my Website Hosting.
    Located the file: /SocialNetwork/wp-content/themes/woffice/framework-customizations/extensions/woffice-birthdays

    Once I did that I renamed it, it seems to be working fine now!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Warning & Fatal Error! Please Help’ is closed to new replies.
Skip to toolbar