Skip to:
Content
Pages
Categories
Search
Top
Bottom

when logging in, wp-login.php blank

  • Hello everyone!

    I am trying to setup buddypress on my pc to test it out and see if I can eventually start a site. I am a bit new to wp. Whenever I install buddypress, it seems to work but when I log in from the homepage it takes me to http://127.0.0.1/wp-login.php and all I see is a blank page. It does actually log me in, I can go back to the home page and then browse the site fine but I cannot stop the initial blank page from popping up every time.

    Here is some info that may or may not be useful:
    -I am running windows 7
    -I have wamp installed and working
    -wordpress works fine when buddypress is deactivated
    -I am not using any other plugins, everything is set to the default settings minus changing the permalinks for buddypress. Nothing else was added to wordpress, it’s just there to get buddypress up and testing
    -I can uninstall wp, delete the mysql table and reinstall everything from a clean slate and still see this problem
    -wp is in the root directory
    -I have turned on the wp debug and I see no errors. There are no errors in the php or apache logs either.

    Any help would be much appreciated, look forward to hearing from everyone!

    JJG

Viewing 6 replies - 1 through 6 (of 6 total)
  • Install xampp it’s a better AMP package, set up your httpd,conf file for Apache to use vhost containers, use your hosts file to set local domain e.g mysite.dev then you can run as many installs as you like from a directory of your choice along with fully qualified domains albeit locally resolved.

    Thanks for the fast reply! I got xampp running and reinstalled wp and bp. I am still seeing the blank page when logging in, it works if I use the wordpress log in but if I use the log in on the side bar of the default buddypress theme I just get sent to a blank page. Is there anything else I might have setup incorrectly that would cause this?

    Difficult to say without seeing more detail of your installation, did you get domain name resolving set up, resolve a domain name to localhost / 127.0.0.1 and httpd using vhost containers so you can say mysite.dev is ServerName and it’s Documentroot = /the/folder/containing/site/files.

    There should be examples commented out in httpd.conf and httpd-vhosts.conf

    I am still having trouble with this:(
    I have vhost working. Just playing around with the apache settings, I am able to make several working generic sites, ie. site1.dev under /rootfolder/site1/, site2.dev under /rootfolder/site2.. and so forth. Unfortunately I don’t have access to another computer to try this on, but I’m pretty sure there is just something wrong with my home setup. Like, if I actually purchased web space and put wp and bp up it would probably work fine, but I really want to be able to test everything out on my own pc first.

    What other information about my installation setup do you think would be helpful? I tried using both xampp and wampserver2.2D, I prefer the latter. I used them one at a time, never installing both at once. I pretty much just downloaded the installers and left everything default, I didn’t have any prior sites I was working on before on this computer. For wampserver I had to delete the # symbol to uncomment the line ‘#Include conf/extra/httpd-vhosts.conf’ but that is all I had to change. xampp does not comment that line out on a clean install. There were no problems with wordpress on either setups.

    My mind is boggled!

    and you have host entries in the form of 127.0.0.1 site1.dev and .htaccess in site doc root, mod_rewrite enabled in httpd.conf.

    Yes, host entries setup, .htaccess in the root folder, and mod_rewrite is enabled in http.conf. Still seeing this problem:(

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘when logging in, wp-login.php blank’ is closed to new replies.
Skip to toolbar