Skip to:

Widget Ajax Problem on Members/Groups

Viewing 6 replies - 1 through 6 (of 6 total)
  • Profile photo of John James Jacoby
    John James Jacoby


    You have javascript errors that are causing the other scripts to stop.

    jQuery("div#members-list-options a").livequery is not a function - line 3 of:

    shutterReloaded is not defined - line 1 of:

    Fix those and see if your ajax returns.

    Profile photo of Burt Adsit
    Burt Adsit


    Hey John! See you got an upgrade. Thank God the cavalry is arriving :) Welcome to being part of the solution. Course you have been since you got here.

    Sometimes I find that error to be an older version of jquery being used by another plugin.

    Profile photo of John James Jacoby
    John James Jacoby


    Haha Thanks! Happy to help! :D

    I’ve also noticed that WordPress can be particular about the jquery version it’s using also. I’ve tried upgrading to the newer versions just to be on top of things, and it usually breaks something.

    Profile photo of 12thharmonic


    OK, this looks like the issue I am having. Using WooThemes Premium News. The free one.

    I’ve hacked it for BP including the featured image thing. All fine, but this jquery conflict.

    I’ve read this thread and another.

    I understand the version conflict. I am however having real trouble finding where to fix it.

    Firebug outputs the following.

    $ is not a function… (line 1272)

    [Break on this error] $(function() {

    headonra… (line 1272)

    $ is not a function

    [Break on this error] $(document).ready(function(){

    headonra… (line 1253)

    jQuery(“div#members-list-options a”).livequery is not a function

    (?)()()widget-m…ver=2.7.1 (line 3)

    (?)()()jquery.j…e3Q%3D%3D (line 1)

    (?)()()jquery.j…e3Q%3D%3D (line 1)

    (?)()([function(), function(), function(), 2 more…], function(), undefined)jquery.j…e3Q%3D%3D (line 1)

    (?)()()jquery.j…e3Q%3D%3D (line 1)

    [Break on this error] function() {

    widget-m…ver=2.7.1 (line 3)

    I feel I’ve wandered down the right path, yet I can’t read the street numbers.

    Any help would be appreciated.

    Profile photo of Warwick Booth
    Warwick Booth


    I have been having the same problem, but I have noticed that my second level drop down are not working aswell.

    I have the Flutter plugin v 1.1 installed and working. I tried disabling plugin by plugin to see what was the problem and it turns out Flutter was causing the conflict. Still working on it.

    This thread is a) old, b) about plugins rather than BuddyPress itself and c) about to be eaten by a grue.

    Any uncompatibilities need to be discussed with the authors of these plugins. There is also enough google results about jquery incompatibility with WordPress and plugins.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Widget Ajax Problem on Members/Groups’ is closed to new replies.
Skip to toolbar