Skip to:

Widget Bugs

  • subster


    Hi there,

    if i edit an widget, for example the welcome-widget, i only get on letter in the output. My typed in text in the backend is lost and i’ve no chance to fill in content.

    Now i wanted to limit the acticivity stream widget to 10 entries. Saved, but nothing changed in the frontend. In the widget, is now an f instead of my filled in 10.

    Any ideas?

Viewing 7 replies - 1 through 7 (of 7 total)

  • subster


    Update: Very strange behaviour!

    As i wanted the functionality of the activity-widget back, i deleted the db, and imported a dumb taken a few minutes before i tried to edit the widget-option.

    Now, no widget is updating, activity widget, who’s online and so on… All gone static

    Jeff Sayre



    First, you should not edit the core files–this includes the widget files. Instead, make copies of the widget files that you want to modify, give them a unique name, and then work on those copies. You can then install and activate your new widget in WPMU’s backend like any other widget.

    Second, before modifying any widget, you should remove it from any BuddyPress theme column in which it is installed. This is just a wise precaution.

    Third, I’d suggest copying back to their original locations, unaltered versions of the widget files that you modified.

    Making a backup copy of your DB is always a good idea before any modification that can impact the data. But, as far as what you’ve done with your actual data in you DB, I cannot advise.



    Tahnks for this wise advices, i’ll follow in the future…

    Jeff Sayre



    Is this problem solved? If so, please set the light to green (resolved) above.



    I’m having the same issue regarding the buddypress welcome widget.

    I have buddypress working 100% on server_1 and I moved it to server_2.

    I used gzip through SSH to compress the html directory containing the entire WordPress Mu and Buddypress installation. Then I used scp through SSH to transfer the tarball to server_2 and then extracted it.

    I exported the MySQL database from server_1, and opened it in Notepad++. I did a search and replace for the changing it to the I also search and replaced the directory path from /usr/local/apache/htdocs to /var/www/html. Then I imported the database to server_2 in a table with the same name as the old server, then edited the wp-config.php to use the new database.

    In theory all this should work, but the only thing that isn’t is the text on the welcome widget, I can change it etc but it only displays the first character. Other widgets save and work fine, it’s seems to be just an issue with this one. I also haven’t altered any of the core files. I’ve also tried removing commas, etc in the MySQL for the welcome widget content portion before importing it.

    I’m going to tinker with it further, such as disabling all widgets/plugins before moving the database to the new server, then enabling them. I know WordPress suggests this when migrating to a new server, although I have never needed to before. I’m using WordPress Mu 2.7.1 and Buddypress 1.0.

    Thanks for any ideas.



    I’m haveing exactly the same issue when I updated WPMU from 2.7.1 to 2.8.1.

    I’ve tried to install another buddypress by using newly installed 2.8.1 and the same problem appears.

    More precisery, all the text fields from welcome message to “how many xxs do you want to have” fields retains only one letter in a field.

    I haven’t touched the core files of neither WPMU nor Buddypress. I’ve just put them on the server and installed/activated.

    However, when activating Buddypress on 2.8.1, I’ve got an error massage saying that Buddypress could not be activated, although it IS activted in the plugin list (and working fine, except this widget issue.)

    Running under PHP5.2.8 and MySQL 5.0.77.

    Paul Gibbs


    Andy Peatling has said he plans an interim of BuddyPress soon to improve compatibility with WPMU 2.8.1 (via twitter). If this isn’t on the bug tracker, please post it so that he is aware – thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Widget Bugs’ is closed to new replies.
Skip to toolbar