Skip to:

WordPress Plugin Not being applied

  • I have a WordPress Plugin that is supposed to be applied, through JQuery, to every element ID that I designate (CLEditor to be precise). It works in WordPress, but it does not seem to be being applied to elements created under BuddyPress.
    I have even tried creating new textarea elements with unique ID’s inside the buddypress theme. The elements show up, but still the plugin does not seem to be being applied.

    I do not think this is a plugin problem since it works fine for both wordpress and bbPress 2.0 content.
    Any ideas would be greatly appreciated!

Viewing 3 replies - 1 through 3 (of 3 total)
  • whoops! found it, fixed it, behavior was due to plugin testing for “is_single()” which apparently was false for all of the buddypress pages.

    Which begs the question… when if ever is is_single() true in bp 1.5 and what should be used instead to test for pages where text areas might appear?



    Depends on what you mean by “single” in BuddyPress.

    If you mean a user’s profile page, that would be `bp_is_user()`; for a group page, it would be `bp_is_group()`.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WordPress Plugin Not being applied’ is closed to new replies.
Skip to toolbar