Skip to:
Content
Pages
Categories
Search
Top
Bottom

Activation Process messed up

  • Avatar of suziwilson
    suziwilson
    Participant

    @suziwilson

    I am using WordPress 3.2.1 and Buddypress Version 1.5.1 along with s2member Pro Version 111029. The BuddyPress registration process seems to work fine until it comes to activation.

    The user gets the email they are supposed to get which send them to the Activate/key=? page with a key. That screen says: “Account Activated: Your account was activated successfully! You can now log in with the username and password you provided when you signed up.”

    However when the user log’s in they are sent back to the Activate page which says:
    “Activate Your Account Please provide a valid activation key.”
    Typing in the key gives the user an error message.

    Can someone tell me how to get the user out of this loop?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Could be s2member Pro conflict. Deactivate plugin and test without it.

    Avatar of suziwilson
    suziwilson
    Participant

    @suziwilson

    Nope. It isn’t s2member. I unplugged it and the exact same sequence of events occurred.

    Avatar of suziwilson
    suziwilson
    Participant

    @suziwilson

    Mercime, If you need me to show you something that would help you help me figure out what the problem is I would be glad to send it to you. I plan to go through the s2member set-up again to see if there is something I can figure out there.

    Thank you, i advance for your help.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    http://wordpress.org/extend/plugins/unconfirmed/ – use this to view and activate unactivated accounts.

    I have not encountered that activation issue before. To troubleshoot, I would:
    – Deactivate all plugins including BuddyPress and change to Twenty Eleven theme. Check registration on regular WordPress install. If activation doesn’t work, resolve this first in WP forums and with webhost. If registration/activation works proceed to next step.
    – Activate BuddyPress plugin only and change to bp-default theme. Check registration/activation here. If it doesn;t work, file ticket at https://buddypress.trac.wordpress.org/newticket (log in with same username and password). It activation works, proceed to activate your theme and other plugins then test again.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.