Skip to:
Content
Pages
Categories
Search
Top
Bottom

Avatar Problems – Upload failed! – Cannot move to upload folder

  • Avatar of Maxaud
    Maxaud
    Participant

    @maxaud

    I’me getting this error when I try to upload any avatar:

    “Upload Failed! Error was: The uploaded file could not be moved to the upload folder.”

    Normal WordPress uploads are working fine.

    Working on WPMU 2.7 “Bleeding Edge” and BuddyPress r832

Viewing 25 replies - 1 through 25 (of 30 total)
  • Avatar of Maxaud
    Maxaud
    Participant

    @maxaud

    I should also add that I’ve tried with the following directories chmod 777 with no luck.

    wp-content/

    wp-content/blogs.dir/

    wp-content/blogs.dir/1/

    wp-content/blogs.dir/1/files/

    wp-content/blogs.dir/1/files/avatars/

    I’ve also tried uploading images that were way too big or way small and still got the same error.

    Avatar of Multimedium
    multimedium
    Member

    @multimedium

    I am having the exact same problem. First, I got an error saying that the folder wp-content/blogs.dir/1/files couldn’t be created. Then, I chowned the wp-content folder recursively, which then resulted in the error you are getting. The only difference is that I’m using the current stable version of MU, 2.6. I have searched for hours and I’m not finding a solution. Help!

    Avatar of Maxaud
    Maxaud
    Participant

    @maxaud

    I ahd the same problem.

    Couldn’t be created and then it couldn;t be moved.

    It’s working fine on a test 2.6.5 install that I have.

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    The seems like it may be an ownership problem on those folders? I think the owner of the folders needs to be apache or www.

    Avatar of Maxaud
    Maxaud
    Participant

    @maxaud

    re-installed with most recent version of both WPMU-bleeding edge and BuddyPress and it seemed to fix the issues.

    I don’t think it was a BP or WP issue but a server problem.

    Thanks for helping.

    Avatar of Djsteve
    djsteve
    Participant

    @djsteve

    I had the same error.

    I tried to change blogs.dir to 777 and the folders within it to 777, but my ftp gave an error.

    Then I noticed was that my blogs.dir folder was “owned” by nobody.

    So my server peeps changed the ownership of the folders,and I was able to make them 777. Then I noticed that mu/buddypress made a new folder “02″ down a few folders.. but then I still got the upload error.

    after many more emails my server admins found that:

    The issue was that a directory ournewbuddypresssite.com/avatars needed to be created and given permissions of the web server.

    hope this helps anyone with similar issues, and perhaps an update may be needed to the install documentation? not sure if it’s just me or my server issues though..

    (fresh install with Mu V 2.7 and bpress beta2 I’m pretty sure)

    Avatar of Ddegraw
    ddegraw
    Participant

    @ddegraw

    thanks DJ Steve!! That solved it for me :)

    Avatar of Jimthedj65
    jimthedj65
    Member

    @jimthedj65

    I updated to the latest svn build tonight and it solved it… I think it was a BP code issue.. Noticed that add friend no longer works…

    Avatar of Frumph
    Frumph
    Participant

    @frumph

    Having the problem today.

    Avatar of Angie_Jones
    Angie_Jones
    Member

    @angie_jones

    Had the same problem, when I moved my site to a new host. It was also the file owner who caused that trouble.

    Avatar of Frumph
    Frumph
    Participant

    @frumph

    whats the directory path(s) it saves to, then moves the file to?

    Avatar of MartinNr5
    MartinNr5
    Participant

    @martinnr5

    wp-content/blogs.dir needs to be writeable.

    The 1.0b2 build had a problem with this though (at least for groups). When upgrading to RC1 the problem went away for me.

    Avatar of Frumph
    Frumph
    Participant

    @frumph

    yeah but on windows server 2008 its heirarchal permissions and everything is set so pretty unsure what the problem could be at this point

    Avatar of MartinNr5
    MartinNr5
    Participant

    @martinnr5

    What permissions do you have set? “Everyone”, “Full access”?

    Avatar of mkgold
    mkgold
    Participant

    @mattkg

    Running into this problem today, and creating an avatars folder didn’t help. Does anyone have another solution?

    Avatar of Mascix
    Mascix
    Participant

    @mascix

    same problem couldnt solve the chown or chgroup or chmod. what else can I do ?

    Avatar of mkgold
    mkgold
    Participant

    @mattkg

    Has anyone been able to find a solution to this yet?

    Avatar of mkgold
    mkgold
    Participant

    @mattkg

    Hi Everyone,

    I have solved this problem on my installation with help from a very wonderful sysadmin. Here are the two steps we took to make this work:

    - PHP safe_mode turned OFF

    - PHP able to execute the “readfile” function.

    Now that we’ve done that, things appear to be working. I hope this solution works for others.

    Avatar of Keston
    keston
    Participant

    @keston

    @mattkg: Thanks a lot, its working fine for me with safe mode OFF.

    Avatar of Vito687
    vito687
    Participant

    @vito687

    Im having the same problem on the latest branch of WPMU2.7.1 and latest trunk of BP

    Avatar of Vito687
    vito687
    Participant

    @vito687

    ::wrong forum::

    Avatar of Kenneth Jensen
    Kenneth Jensen
    Participant

    @kennethj

    Having the same problem with avartars.

    Anything new here?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Anything new since two months ago? There have been many changes to BuddyPress over that time!

    Have you searched the forum and read this thread

    If so, then you need to provide more of an explanation than “Having the same problems with avatars”. That tells us exactly nothing to begin the process of providing support. Please see this thread as well.

    Avatar of mhoo mu
    mhoo mu
    Participant

    @mhoohu

    Oh, It’s working fine on set safe mode off

    Avatar of erikshosting
    erikshosting
    Member

    @erikshosting

    Just thought I’d mention that I had this issue and solved it by checking that the blogs.dir folder AND ALL SUBFOLDERS, RECURSIVELY, were set to ownership by ‘apache’ and had 775 permissions.

    This took some time to trouble shoot, as it turned out my host was only setting the blogs.dir folder to ownership by ‘apache’ and not its sub-folders. I had to specifically ask a second tech support guy to check the sub-folders for me before I figured this out.

    ‘apache’ needs to be the owner on apache machines, the rest should have the main ftp user as the owner (you may have to enable group permissions so you can still edit them)

    I Hope this article I wrote helps: http://erikshosting.com/wordpress-tips-code/buddypress-avatar-upload-failed-fix/

Viewing 25 replies - 1 through 25 (of 30 total)

You must be logged in to reply to this topic.