Skip to:
Content
Pages
Categories
Search
Top
Bottom

bp-custom-php help

  • Avatar of Ezd
    Ezd
    Participant

    @ezd

    Hi,

    I was trying to make a new slug for members by following the guide on how to do that but I cant get it to work.

    I added a file called bp-custom.php to this location: wp-content/plugins/buddypress/bp-custom.php

    And i added this code to the file

    <?php
    define( 'BP_MEMBERS_SLUG', 'players' );
    ?>

    Whats wrong?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of wpmubp.org
    wpmubp
    Participant

    @takuya

    It should be working. (place your bp-custom.php outside buddypress as it will be deleted when you upgrade buddypress next time by wordpress update system)

    Avatar of Ezd
    Ezd
    Participant

    @ezd

    Thanks once again Socialpreneur. :))) Now it works.

    Avatar of blackarbor
    Anonymous

    I’m trying to do this as well, however, it’s not working. I have my buddypress.po and buddypress.mo in my bp-languages folder and I uploaded a new bp-custom.php to the /plugins/ folder however, from there how do I enable the new translation?

    I’m using:

    <?php
    define( 'BPLANG', 'mysite' );
    if ( file_exists( BP_PLUGIN_DIR . '/bp-languages/buddypress-' . BPLANG . '.mo' ) ) {
    load_textdomain( 'buddypress', BP_PLUGIN_DIR . '/bp-languages/buddypress-' . BPLANG . '.mo' );
    }
    ?>

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    You need to remove the “- ‘.BPLANG.’” suffix from the .po/.mo files in your bp-custom.php

    Use this:

    <?php
    define( 'BPLANG', 'mysite' );
    if ( file_exists( BP_PLUGIN_DIR . '/bp-languages/buddypress.mo' ) ) {
    load_textdomain( 'buddypress', BP_PLUGIN_DIR . '/bp-languages/buddypress.mo' );
    }
    ?>

    Avatar of blackarbor
    Anonymous

    *bow*

    Thanks r-a-y, once again you have proven to be very knowledgeable :).

    Avatar of tore_gu
    Anonymous

    This thread helped me! Thanks a lot guys!

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.