Skip to:
Content
Pages
Categories
Search
Top
Bottom

bp_has_members ignores user

  • Hi there!
    I’ve run into very strange problem with bp_has_members function. I’m using such arguments:
    `include=1,13,14,16,17,19,20,21,22&per_page=100&max=100`
    For some reason just one user, e.g. id 21 is ignored in function. All users have subsciber account type and no difference between them. I would be really grateful for any ideas.

    WP: 3.2.1
    BuddyPress: 1.5

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    > just one user, e.g. id 21

    It is always id 21 ?
    It it always a random id from your include string ?
    How do you know it’s ignored ?
    etc, etc.

    Use pastebin or gist and show us the code you use to create the include string and any custom code you may be using in bp_has_members

    Sorry for taking so long to answer, I was away from town for a few days. Yes, it is always only this one member getting ignored. Here are links to code samples.

    In template: http://pastebin.com/dys9czZK
    In function: http://pastebin.com/ZUUisdM5

    Avatar of CommonEasy
    CommonEasy
    Participant

    @commoneasy

    Hi, sorry to bump this old topic, i was wondering if you found a solution to your problem? I face the same issues here…

    Avatar of Łukasz Wilk
    Łukasz Wilk
    Participant

    @wilku_

    Unfortunately I wasn’t able to find any anomaly with this particular account. I created a new account for that user and assigned him all activity from old account. Sorry, afraid I can’t much of help.

    Avatar of CommonEasy
    CommonEasy
    Participant

    @commoneasy

    hmmm very strange, i use the custom loop inside the buddypress profile and found that users who are not connected to /have a friendship with the displayed users are ignored by the loop.

    Avatar of Łukasz Wilk
    Łukasz Wilk
    Participant

    @wilku_

    Hmm that’s really strange. It might be a good idea to contact BuddyPress developers if you are sure that this is the issue.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.