Skip to:

bp_has_members ignores user

  • Hi there!
    I’ve run into very strange problem with bp_has_members function. I’m using such arguments:
    For some reason just one user, e.g. id 21 is ignored in function. All users have subsciber account type and no difference between them. I would be really grateful for any ideas.

    WP: 3.2.1
    BuddyPress: 1.5

Viewing 6 replies - 1 through 6 (of 6 total)
  • Profile photo of shanebp


    > just one user, e.g. id 21

    It is always id 21 ?
    It it always a random id from your include string ?
    How do you know it’s ignored ?
    etc, etc.

    Use pastebin or gist and show us the code you use to create the include string and any custom code you may be using in bp_has_members

    Sorry for taking so long to answer, I was away from town for a few days. Yes, it is always only this one member getting ignored. Here are links to code samples.

    In template:
    In function:

    Profile photo of CommonEasy


    Hi, sorry to bump this old topic, i was wondering if you found a solution to your problem? I face the same issues here…

    Unfortunately I wasn’t able to find any anomaly with this particular account. I created a new account for that user and assigned him all activity from old account. Sorry, afraid I can’t much of help.

    Profile photo of CommonEasy


    hmmm very strange, i use the custom loop inside the buddypress profile and found that users who are not connected to /have a friendship with the displayed users are ignored by the loop.

    Hmm that’s really strange. It might be a good idea to contact BuddyPress developers if you are sure that this is the issue.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘bp_has_members ignores user’ is closed to new replies.
Skip to toolbar