Skip to:
Content
Pages
Categories
Search
Top
Bottom

Buddypress + Multisite, Add New Site Option

  • Avatar of Alexander
    Alexander
    Participant

    @ashenkargmailcom

    I’m running the latest version of BP with Multisite. Somehow, the option for registered members to add a create a new site has disappeared. In the Network Settings I have “Both sites and user accounts can be registered” enabled. I’ve also tried the option, “Logged in users may register new sites.”

    What I’d like to be able to do is allow community members to register their own site after they log in. I don’t see any such options in the top admin bar, nor under the user’s Sites profile tab. I believe previously there used to be a button under the Sites tab that allowed the users to create a new site but now it’s gone.

    What am I missing? I’ve tried enabling a default theme too but it didnt make a difference.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    BP Default theme -> Go to the Blogs Directory page. There’s a “Create A Blog” link beside the title, Blogs Directory.

    Avatar of Alexander
    Alexander
    Participant

    @ashenkargmailcom

    @mercime Thanks! There it is. I could have sworn that there was also a button to add a new blog under the profile’s Sites tab. I know for a fact that there used to be that option in the top admin bar in the previous BP version. Any idea how to add a ‘create blog’ button or link to that top admin bar? Thanks

    Avatar of myladeybugg
    myladeybugg
    Participant

    @myladeybugg

    @Alexander Did you ever find the create blog link? I am running into the same situation as you. I need users to be able to create a blog after registration.

    I did find a link in the dashboard under ” my sites” that says “create a new site” but the link is dead. It brings me to a “page not found”.

    well there should be a button on your blogs page (or whatever you have named your network directory page).

    Avatar of myladeybugg
    myladeybugg
    Participant

    @myladeybugg

    @ubernaut Where I would I find this button? Is it a widget? I do not see any button anywhere on my page.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @myladeybugg That button/link only shows up for multisite installations and it shows up right beside the page title of the Blogs Directory page e.g. Blogs

    Avatar of myladeybugg
    myladeybugg
    Participant

    @myladeybugg

    @mercime Maybe I am totally lost here, but I am guessing my blogs directory page is my main install page? I am running multisite and need my users to be able to create a blog after they register because my registration process is done through a different forum software.

    I installed wordpress multisite into domain.com/blogs. I then installed buddypress and activated it. So, is my blog directory page domain.com/blogs? If so, I still do not see a button.

    Thanks for the help.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    I installed wordpress multisite into domain.com/blogs

    @myladeybugg just to be clear, you installed WP in subdirectory at example.com/blogs and BuddyPress is installed at main site of WP at example.com/blogs, right? Then Blogs directory page should be at example.com/blogs/blogs (assuming your blogs page name is blogs). Or did you install BP in a secondary blog of your multisite installation e.g. example.com/blogs/site2?

    Also BuddyPress must activated sitewide in Network Admin. If you did so, go to Settings > BuddyPress > Components, is your Site Tracking checked?

    Avatar of myladeybugg
    myladeybugg
    Participant

    @myladeybugg

    @mercime Thank you!

    I went to domain.com/blogs/site-tracking and found the button there!

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @myladeybugg you’re welcome :-)

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.