Skip to:
Content
Pages
Categories
Search
Top
Bottom

checkbox xprofile field – default "checked"

  • Avatar of BobSD99
    BobSD99
    Participant

    @bobsd99

    using WordPress 3.5.1., BP 1.7.1.

    I’ve created a custom checkbox field for “Newsletter” in the “base” group for the user’s xProfile. I would like this field to be checked by default (user consents to newsletter). I set the default value as “Yes” in the configuration, but this doesn’t appear to load the field as checked. I tried adding a second value, “No,” which of course is not default, but that didn’t make the default field checked either. This is the expected behavior with “default” for checkbox, am I doing something wrong?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of bp-help
    bp-help
    Participant

    @bphelp

    @bobsd99
    Your right, in my test it does not show up either. I believe this is a known bug for xprofile fields for logged out users. Maybe @hnla or @mercime can shed some more light of whether a trac ticket has been submitted on this issue.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Search trac for tickets on the subject I reported on one issue ages back with select options.

    As far as I’m aware the ‘default’ in select terms simply means that which appears first or would be selection if simply returned, possibly this needs looking at for checkboxes, but as for behaviour I would expect the intial value to be false or 0 these are profile fields for users to set not you if that makes sense, and on that note really and truly you shouldn’t opt people in nothing more annoying than being auto opted in and somewhat frowned upon correct way is let people choose to opt in to emails / newsletters

    Avatar of bp-help
    bp-help
    Participant

    @bphelp

    @hnla
    Well said Hugo! It also seems to me that if it was checked by default it would make it even easier for spam bots to compromise a site.

Viewing 3 replies - 1 through 3 (of 3 total)

The topic ‘checkbox xprofile field – default "checked"’ is closed to new replies.