Skip to:
Content
Pages
Categories
Search
Top
Bottom

Date format and language

  • Avatar of Andres Felipe
    Andres Felipe
    Participant

    @naturalworldstm

    I don’t know why but since a few days the BP pages change the date format and language as You can see here:

    Date example

    It must be es_ES but is en_EN. I think this could be because a plugin… Is there any way to add something in functions.php or style.css to made the default BP date mandatory and the language es_ES mandatory?

    Thanks in advance!

Viewing 17 replies - 1 through 17 (of 17 total)
  • Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Did this work before? What did you change since then?

    Avatar of Andres Felipe
    Andres Felipe
    Participant

    @naturalworldstm

    Hi @djpaul

    Yes it does, I have made many changes in plugins, css and didn’t realize when this happens. Is there any way to make this mandatory? something like `!important` or anything else?

    Thanks for your reply!

    Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    ola @naturalworldstm,

    do you use bp-media or bp-album ? Verify that you have the translation file for it.

    !important concern only css, and x days ago translation has nothing to do with css.

    Avatar of Andres Felipe
    Andres Felipe
    Participant

    @naturalworldstm

    Hi @chouf1 I use bp-media (actually recently), I have the translation file and I translate its po file to es_ES. I try deactivating this plugin but still the same. Any idea?

    More info: In BP pages the date format remains but the language not and in not BP pages the date format doesn’t remains, I can see this because the activity stream bar in footer (You can see it in the image)

    The most important thing is the language, the format is a secondary problem.

    Thanks for your reply!

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @naturalworldstm there are a couple of BP media plugins. Are you referring to http://wordpress.org/extend/plugins/buddypress-media/ ? if so, please also post at their support forums http://wordpress.org/support/plugin/buddypress-media

    Avatar of Andres Felipe
    Andres Felipe
    Participant

    @naturalworldstm

    Hi @mercime, Yes that is the plugin I’m using but I’m not sure about the problem would be because of it. I deactivate it and the problem remains.

    Anyway, I’ll try their support forums.

    Thanks for your reply!

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @naturalworldstm my question was based on the previous post, not the original post. So just to make sure that it’s not your default install that’s causing the issue.
    - Check if any changes were made in your Settings > General. Make sure you’re using the UTC+/- selection instead of city name.
    - Deactivate all plugins except BuddyPress, refresh browser and check if time is corrected.

    Avatar of Andres Felipe
    Andres Felipe
    Participant

    @naturalworldstm

    Ok thanks for your reply, I’ll try it and update this topic.

    Avatar of Andres Felipe
    Andres Felipe
    Participant

    @naturalworldstm

    Hi @mercime

    - Check if any changes were made in your Settings > General. Make sure you’re using the UTC+/- selection instead of city name.

    I was using city name, and changed it to UTC-5, nothing happens

    - Deactivate all plugins except BuddyPress, refresh browser and check if time is corrected.

    Deactivate all plugins except Buddypress and nothing happens

    Could it be something in the wp-config?

    Thanks for your time!

    Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    SWA has a date in english, you change to spanish and now SWA is in spanish and previous activities are in english. It’s just normal !

    Now you have verified and nothing changed. Have you create a new content meanwhile ? Deactivating and reactivating plugins has no influence on the SWA. If you don’t use specifically this plugin, so far he provides some activity (like add a picture to the album) who goes to the SWA, who don’t see absolutely nothing.

    Could be that if you apply changes about date format in WP settings, or in a plugin, this will not appear in the site wide activity. The modification will only apply after you did the change. SWA has no backward compatibility with settings. Also for language format.

    Sorry for this detail, but it must be knowed before complete headache

    Avatar of Andres Felipe
    Andres Felipe
    Participant

    @naturalworldstm

    Hi @chouf1 and thanks for your reply

    The thing is the date format and language was ok until… I don’t know. After made the changes suggested by @mercime I try making new activity updates and was the same, this is what happens:

    1. I make an activity update
    2. The activity update appears with a format like this `4 April, 2013 1:23 AM`
    3. After a minute or refresh, the format changes to `less than a minute ago`

    But always keeping the us_US language.

    Thanks for your time!

    Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    @naturalworldstm,

    can you give a site URL please ? Also do you use BP on a multisite or on a single WP ? What PHP version do you use ? And does your host provide gettext with PHP. ?

    http://codex.wordpress.org/User:Ipstenu/How_to_create_a_phpinfo%28%29_page

    Basically, the %s ago thing is a wordpress function – also used by BP on the activity time. If you already checked the BP part, and it seems ok according what you say above, i don’t know what happens so far.
    This issue could be a mistake from the translator or something else directly handled by WordPress.

    If you’re using WP 3.5.1, check the languages folder witch must contain the following files:

    buddypress.mo

    And WP’s default translation files:
    es_ES.mo (for WP in spanish)
    admin-es_ES.mo (dashboard)
    admin-network-es_ES.mo (network dashboard)
    continents-cities-es_ES.mo (a list of cities in your language, used for date/time setting in dashboard, not mandatory)

    If you use bbPress 2.2.x, there should also being a folder /bbPress/ containing bbress-es_ES.mo

    In wp-config.php you must have a line saying
    define(”WPLANG’, ‘es_ES’);

    If you use WP MS, you also have to set the network to your language in the Network Settings.

    If you use a third party theme, it may contain his own /languages/ or /lang/ folder with a pot file at least. This file must be used to translate the theme.The theme translation mo file should be in this folder.

    Some themes are sometimes delivered with .mo files. Unfortunatly, those additionnal mo files are rarely updated. So if the theme has a es_ES.mo or theme-es_ES.mo, you can use the pot file to check or update the theme  translation. In fact, in such case, the only file in witch you can trust, is the pot file. It also can be that the pot is not updated too, which means you have to recreate it from start, with a compiler such as poEdit…. :mrgreen:

    This rule is also valuable for plugins.

    At this point, i suspect a corrupted WP file. To eliminate this possibility, i would try the following.

    Delete the whole wp-includes folder and upload a fresh copy of 3.5.1 via FTP

    http://core.trac.wordpress.org/changeset/23897/tags/3.5.1?old_path=%2F&format=zip

    If you use a previous version, go here:

    http://core.trac.wordpress.org/browser/tags

    Don’t use the right click to download something from Trac repo. Always click first on the file or folder name, and use the download button at the bottom of that page.

    Avatar of Andres Felipe
    Andres Felipe
    Participant

    @naturalworldstm

    Hi @chouf1 and thanks for your extensive and clear reply, to answer your questions:

    1. Site URL link
    2. Single WP but considering Multisite in near future
    3. PHP version 5.2.17
    4. Yes they provide me gettext with php

    About your suggestions:

    1. I’m using WP 3.5.1
    2. Checked the language folder and there were all the files You say except the buddypress.mo, I added it, clear chache, made a new activity update and nothing happens.
    3. Actually the theme has .mo and .po files and I checked them and where ok, no strange translation or mistakes.
    4. I’ll try the wp-include folder option and update this topic again.

    Really, really, thanks for all your time!

    Avatar of Andres Felipe
    Andres Felipe
    Participant

    @naturalworldstm

    UPDATE

    I try downloading the wp-include and nothing happens, I thinks I will try delete all the plugins and install them again. I’ll update this topic after that.

    Thanks for your time!

    Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    @naturalworldstm

    i didn’t say “except” buddupress-es_ES !
    i said
    check the languages folder witch must contain the following files:

    buddypress.mo

    And WP’s default translation files:
    [file list]

    Avatar of Andres Felipe
    Andres Felipe
    Participant

    @naturalworldstm

    Yes, that was just what I did, maybe I didn’t explain myself (sorry for my english)

    Avatar of Andres Felipe
    Andres Felipe
    Participant

    @naturalworldstm

    UPDATE (SOLVED)

    If anybody is getting this issue, unfortunately and fortunately I could find the error. It was a plugin conflict (I don’t know why I couldn’t find it before) with RS Buddypress Activity Refresh and its option “Date format” it was overriding the date format and for some reason language too.

    For the moment I just deactivate it and now everything is ok but is so sad because this is/was an excellent functionality than BP should have in core and the plugin seems not to be developed anymore.

    Thanks to everybody for your support but specially to @chouf1

Viewing 17 replies - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.