Skip to:
Content
Pages
Categories
Search
Top
Bottom

Erroneous message -> Buddypress themes not installed

  • Avatar of Jugularbean
    jugularbean
    Participant

    @jugularbean

    I have activated the themes in the WPMU settings section. I have also installed them in the directory wp-content/bp-themes

    However in the BuddyPress settings it tells me “You do not have any themes installed”

    Also when I try and access the profile section I get the error message

    “You do not have any BuddyPress themes installed.

    Please move “/wp-content/plugins/buddypress/bp-themes/” to “/wp-content/bp-themes/” and refresh this page. You can download more themes here.”

    However I have all the buddy press theme files and more in the right folder.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Only bp themes go into /wp-content/bp-themes. Normal wp themes do not go there. They live in /wp-content/themes as always. If you have just upgraded to 1.0 then the bp member theme directory name has changed from bp-member to bpmember due to changes in wpmu 2.7.1.

    Go to the back end of wpmu BuddyPress > General Settings, make sure the default member theme is selected and press Save Settings. Should go away.

    Avatar of Jugularbean
    jugularbean
    Participant

    @jugularbean

    Thanks for the response Burt.

    I am using WPMU 2.7.1

    However the subfolder within bp-themes is bpmember, so no problems there. And when I go to the wpmu BuddyPress backend I cannot select any themes.

    See screenshots at

    http://70.32.90.231/buddypress-gen-settings.gif

    http://70.32.90.231/wpmu-site-themes.gif

    http://70.32.90.231/ftp-file-structure.gif

    I even tried removing the non BP themes from the BP folder. But it doesn’t make a difference.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Well, the error message is correct. You don’t have any bp themes installed if that gif actually is whey way the files are layed out. The bp-themes folder belongs in /wp-content not in /themes it is *not* a normal wp theme. Please see the readme.txt in /bp-themes.

    Avatar of Jugularbean
    jugularbean
    Participant

    @jugularbean

    AAAAA! I’m so stupid!! I kept reading it as wp-content/themes/

    Sorry. :|

    Thanks for the help, Burt.

    I’m having the same problem, but mine seems to be related only to the “register” page.

    http://www.elsegundo.net/register

    http://www.elsegundo.net/

    I can’t let anyone register. What is the difference between /wp-signup.php and /register?

    I can’t get either to work. I did a clean install on another test domain into a new database and it won’t let me signup anyone either. I get blank screens back with no errors.

    http://mu.wordpress.org/forums/topic/12610?replies=7

    Yeah. Never mind. I’m quitting. Not going to use this any more. Too much trouble.

    Avatar of honewatson
    honewatson
    Participant

    @honewatson

    I moved bp-themes into /wp-content/ as directed but still got the error message.

    Under the “Select theme to use for BuddyPress generated pages:” in general settings the option for using the ‘bpmember’ theme was not appearing. I could only select the default wordpress mu themes. I selected the ‘Default’ theme and then renamed the ‘bpmember’ folder to ‘default’ to get this working.

    Eg:

    ..wp-content/bp-themes/bpmember/

    Renamed it to this folder:

    ..wp-content/bp-themes/default/

    Avatar of rockypersaud
    rockypersaud
    Participant

    @rockypersaud

    I had this problem too… did everything right per the instructions — but I solved it! I was upgrading from a version (1.0b1) where the structure was mainly in the mu-plugins folder. After upgrading database must have still pointed to that location, and so after I deleted the buddypress files in mu-plugins, it gave me the error message.

    All I did to solve it was go to Buddypress -> General Settings and selected the skeleton BP theme, saved settings, then selected the default BP theme, saved settings. I assume that fixed the entry in the database.

    Avatar of Hempsworth
    Hempsworth
    Participant

    @hempsworth

    I’ve installed WPMU trunk via SVN and all is well.

    Then I install BuddyPress via the shell ‘wget’ method, and placed the plugin and theme files in the correct locations:

    /wp-content/plugins/buddypress

    /wp-content/themes/bphome

    /wp-content/bp-themes

    I can activate BuddyPress, but when I go to the /members page for example, I am given:

    You do not have any BuddyPress themes installed.

    Please move “/wp-content/plugins/buddypress/bp-themes/” to “/wp-content/bp-themes/” and refresh this page. You can download more themes here.

    When I visit the wp-admin/admin.php?page=bp-core.php page, the dropdown of themes to select gives me the default WPMU themes – not the BP themes.

    Here are some details about my setup:

    1. Which version of WPMU are you running?

    - 2.8.1-RC1

    2. Did you install WPMU as a directory or subdomain install?

    - Subdomain

    3. If a directory install, is it in root or in a subdirectory?

    - NA

    4. Did you upgraded from a previous version of WPMU? If so, from which version?

    - No, fresh install

    5. Was WPMU functioning properly before installing/upgrading BuddyPress?

    - Yes

    6. Which version of BuddyPress (BP) are you running?

    - 1.0.2

    7. Did you upgraded from a previous version of BP? If so, from which version?

    - No, fresh install

    8. Do you have any plugins other than BuddyPress installed and activated?

    - No

    9. Are you using the standard BuddyPress themes or customized themes?

    - Standard, for now

    10. Have you modified the core files in any way?

    - No

    11. Do you have any custom functions in bp-custom.php?

    - No

    12. If running bbPress, which version?

    - Not running, yet

    13. Please provide a list of any errors in your server’s log files.

    - No errors

    Avatar of Hempsworth
    Hempsworth
    Participant

    @hempsworth

    I’ve since uploaded everything again and it’s working – second time this has happened – I have NO idea what was wrong! :)

    Alex

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.