Skip to:
Content
Pages
Categories
Search
Top
Bottom

Extended Profile Deletes Base Profile "Display Name"

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @solutionstriwareca Have not ever seen this issue before. Could you provide more information about your installation? Is this a fresh installation or did you upgrade from another WP or BP version?

    Avatar of sokrates
    Sokrates
    Participant

    @sokrates

    Hi, Just in case it’s of use….

    I’m a bit of a BP newb, and I’m using a fresh install of WP 3.9.2 and BP 2.0.1

    I’m using a Gravity form as a registration form with the GravityForms User Registration add-on to register BuddyPress users.

    As a newb, I have been experimenting a lot with the XProfile fields, and also noticed that at some stage of the proceedings, I had made a change that resulted in the same problem as in the first post – the WordPress last name value was deleted and the firstname field was set to the nicename when the update profile button was pressed.

    I had changed the primary field in the XProfile fields from “Name”.

    Replacing the primary field as Name, and mapping the “full name” field from the Gravity form to this field in the Gravity User Registration add-on screen seems to solve it for me

    @sokrates,

    thank you for your reply!
    You found a solution with a third party plugin. Glad it works for you, but it doesn’t really help BP users encountering the issue discribed by @solutionstriwareca. An issue which is, as @mercime said, “never seen before”. In other words unknown.

    Let’s try to stay on a buddypress pov first, before searching workarounds.

    Avatar of sokrates
    Sokrates
    Participant

    @sokrates

    Sure, sorry! If the OP is still following the thread – have you changed the primary filed in the XProfiles from “name”?

    Avatar of sokrates
    Sokrates
    Participant

    @sokrates

    In fact it sounds like this issue from 3 yrs ago: https://buddypress.trac.wordpress.org/ticket/3725

    @sokrates,

    the ticket is fixed and closed since 19 mounth.
    If you follow the last IRC discussion around this ticket – 7 mounth ago – you’ll see that the issue cames again, and a new fix was added.

    Also from IRC, test this setting.

    Anyway, if you think the issue is still there, feel free to open a new ticket and give the steps to reproduce. Follow Boone’s instructions

    Login to Trac use the same credentials as bp.org forum.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.