Skip to:
Content
Pages
Categories
Search
Top
Bottom

Group Invite Accept/Reject Buttons Don’t Work – on Windows Server

  • Avatar of dcavins
    dcavins
    Participant

    @dcavins

    I’m troubleshooting some conflicts, and can’t figure this one out. All of the other BP AJAX buttons work— Request Friendship, Reply to an activity stream post, Cancel Friendship, the order switching buttons in the Members and Group widgets work— but the Accept/Reject buttons on a member’s Groups>Invitations page dumps to a “Are you sure you want to do that—Try again” WP failure page. I thought it could be a nonce or AJAX problem, but haven’t solved it. I’ve deactivated every plugin except BP & BP Template Pack, and it still doesn’t work. I should also mention that it works fine on my MAMP install, but not on the web server. Any thoughts?

    Thanks in advance.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Avatar of dcavins
    dcavins
    Participant

    @dcavins

    Oh, and it also fails if I use the BP Default theme, not just my custom theme.

    Avatar of dcavins
    dcavins
    Participant

    @dcavins

    No ideas? One other thing doesn’t work: activation. Could these be redirect failures?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    BP/WP versions?
    Linux or Windows hosting?
    New install or recently upgraded?
    How did you set up your install online, via DB import of data from MAMP?

    Avatar of dcavins
    dcavins
    Participant

    @dcavins

    Hi @mercime-

    Thanks for your reply.

    Latest versions of BP/WP (3.3.1/1.5.3.1). The problem install is Windows hosted (MAMP install is Linux, of course). New install. I set the db up on the server fresh, and only imported posts to it, not settings. As part of troubleshooting, I imported the server install db into an empty MAMP install, and everything worked fine. It only seems to fail on the Windows server.

    Thanks,

    -David

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @dcavins sorry, have never used a Windows server for any WP/BP installation. Perhaps someone with Windows server experience can help you out. Note: Added – “Windows Server” to this Topic’s title for clarity.

    Avatar of dcavins
    dcavins
    Participant

    @dcavins

    @mercime It’s been a little frustrating because everything works perfectly in MAMP and on my testing server (Linux), then there are problems on the production server. I think the problem is in the redirect module, but I don’t know the first thing about fixing that kind of problem on IIS. Thanks for your reply.

    Can you create WordPress Pages ok? What do your permalinks for those look like? Can you create BuddyPress groups?

    Avatar of dcavins
    dcavins
    Participant

    @dcavins

    @djpaul WP pages are fine ( look like /members ). Group creation is fine ( /groups/(group name)/ )
    Accept group invitation links look like `/members/(member name)/groups/invites/accept/4(this is the correct id for the group I’m trying to join)?_wpnonce=(nonce removed by me because it seems like bad security to share?)`
    Working local version link looks like `/members/(member name)/groups/invites/accept/4(correct id)?_wpnonce=(hidden)`
    They seem to be identical, but MAMP knows how to handle it where IIS fails.

    Site is here: http://members.communitycommons.org/

    Thanks for any advice you can give.

    Avatar of toccia
    toccia
    Participant

    @toccia

    @dcavins Hey did you get a solution? I have exactly the same problem on a Linux server (RedHat).
    Latest wordpress and buddypress versions, default theme… Looked all over the internet…

    Avatar of toccia
    toccia
    Participant

    @toccia

    Please help! :)

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.