Skip to:
Content
Pages
Categories
Search
Top
Bottom

Secure Invites for Mu

  • I’ve tried implementing this plugin. I’ve placed the plugin in the mu-plugins like they say to do but it does not show up in my admin panel. When I place the plugin in the plugin directory it shows up and I can change the settings. But when I have it in the plugins directory it only shows up for admin and when i send an invitation to someone and they click on the link they get the sorry, this ssite is for invited members only type thing. Can someone please help me get this working?

    Im using 1.2.4 for buddypress and wordpress mu.

    Thanks,
    eor

Viewing 22 replies - 1 through 22 (of 22 total)
  • Avatar of lpapworth
    SilkCharm
    Member

    @lpapworth

    I have the same issue. I’ve tried posting everywhere to find a fix.
    I suspect it’s a setting eg login page but I can’t figure out which ones.

    This is the main or even only reason I chose to to use wordpress mu. I really need an invite only registration and this plugin is perfect. Please if someone could help me set this up I’d be extremely appreciative.

    I’m sure @lpapworth would appreciate all the help as well.

    Thanks,
    eor

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    This plugin works for me in WPMU install, haven’t tested in WP3.0 multisite. You would need to upload just the plugin file (no need to upload plugin folder) to mu-plugins. Then, although it was not mentioned in instruction, log out, refresh browser and log back in again. See this screenshot for the Settings (Site Admin > Invites) and Invites (Dashboard > Invite). As Chris mentioned, if you’re using bp-default or a child theme of bp-default, invitation template tags will automatically be added in template per your setting via Site Admin > Invites – Edit Settings link.

    I placed the plugin file in the mu plugin folder. And that did make the secure invites show up in my admin panel.

    When I send an invite and the individual clicks the link from their email they always see this message—> “Sorry, you must be invited to join” ….obviously they were invited lol but for some reason the error message comes up…

    What could be causing this? All help would be greatly appreciate as this is the most important plugin for my site.

    Thanks,
    eor

    Avatar of paulhastings0
    paulhastings0
    Participant

    @paulhastings0

    Make sure that the “Signup page” field underneath your security settings at yourwebsitename.com/wp-admin/wpmu-admin.php?page=secure_invite_list&view=settings is filled with the text: “wp-signup.php,wp-login.php?action=register,/register”.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Alternatively, go to Site Admin > Invites. Then in Invites panel click on “Edit Settings” link. Some things to watch out for if you’re using bp-default or its child theme:
    == What is the address of the signup page? (wp-signup.php is the default)
    Signup page == make it register.php
    == What address do you want the invitation emails to send people to? Please add the full URL to the registration page.
    Signup page == if BP is installed in main site == http://yoursite.com/register.php . Or if BP is installed in sub-blog == http://yoursite.com/subblogname/register.php or http://subblogname.yoursite.com/register.php

    Thanks to both @paulhastings0 and @mercime,

    I’ve tried the “wp-signup.php,wp-login.php?action=register,/register” before and that doesnt fix my problem. Mercime I just tried what you have suggested as well and it still doesn’t work. It’s becoming a major frustration! lol. If you’d like to test it out yourself let me know and I can send an invite to you. I really appreciate the help you’ve been giving me. Unfortunately this is an extremely important plugin to my overall concept and its a must fix. so thanks again. I have buddypress and MU installed in my main directory.

    eor

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Check Site Admin > Options – Allow new registrations == must be set to “Blogs and user accounts can be created.”

    Don’t worry about sploggers, when you have WPMU Secure Invites on, no one can register without an invitation — unless of course one of your members invites one…

    I just tried that as well. Still getting the same “Sorry, you must be invited to join” message. Driving me nuts. I think it has something to do with another plugin i have installed. The registered only plugin. When I disable that things seem to run smoothly.. gotta test it out again tho. Gonna have to find another way to keep the site private.

    thanks,
    eor

    Avatar of 1stAngel
    1stAngel
    Participant

    @1stangel

    Yes, this does not work in WP3 and BP unfortunately. It just links to You Must Be Invited. Also in WP3 there is no such thing as mu-plugin folder and if you try and make one then it shows other errors as the hooks will be wrong.

    I hope someone fixes this as it is one of the best plugins out there….just not for the newer wps

    Avatar of Andrea Rennick
    Andrea Rennick
    Participant

    @andrea_r

    The mu-plugins folder is still supported in 3.0.

    But, the plugin still looks like it needs fixing. ;)

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @1stAngel – I agree, it’s the one I use for by-invites-only sites, kudos to Chris Taylor.
    Latest version of WPMU secure invites plugin is working in my WP 3.0 / BP 1.2.5.2 installs and mu-plugins folder fine: WPMU 2.9.2 subdomain install upgraded to WP 3.0. and WP 3.0 multisite subdomain install.

    What or When do errors show, when you create mu-plugin folder and/or upload secure_invite.php file?

    EDIT – @Andrea_r maybe not working for WP 3.0 single site, only for multisite?

    Avatar of 1stAngel
    1stAngel
    Participant

    @1stangel

    I have no wpmu installation but the multisite in WP3. ie I started a new site with the new WP3 and am moving people over as we wanted an all new :)

    I will go and reload the plugin and see what happens. It will mean making a new mu-plugin folder as obviously we don’t get one with a clean wp3 installation. When I had tried that with other plugins it leads to an issue with links (Wibstats for example, although he says he will upgrade that shortly yayyy). Will let people know what happens.

    Avatar of 1stAngel
    1stAngel
    Participant

    @1stangel

    LOL I have made a folder mu-plugins (is that right, brain blank, should it have the s? Anyway now I have nothing in admin. Before I had it in plugins but sitewide activation and could set it up ok :|

    EDITED it cannot be inside another folder….has to be the php on its own… can see it now…sheesh sorry about this guys

    Avatar of 1stAngel
    1stAngel
    Participant

    @1stangel

    Ok, no it doesn’t work…. tested it and got… Sorry, you must be invited to join this community.

    Avatar of Chris Taylor
    Chris Taylor
    Participant

    @mrwiblog

    Sorry that the plugin isn’t working in WP3. I’ll see if I can get some time to fix it. Your patience is very much appreciated.

    Avatar of bpisimone
    bpisimone
    Participant

    @bpisimone

    @MrWiblog I would like to see this evolved into something like invite only communities are using like (dribbble or forrst). So everyone would get a few invite codes to give out. Or is there anything else like that already?

    Or @boonebgorges do you know something, since you’re the creator of the invites plugin.

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    @bpisimone This plugin is separate from my invite plugin, but I’ve been thinking of putting some invite-only functionality into mine. Maybe @mrwiblog and I can join forces somehow :)

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @1stAngel @MrWiblog my bad, the version of the Secure Invites for WordPress MU working in my WP 3.0 installs is Version: 0.9.6. Strange that that version in not in the other versions page of the plugin
    In any case, here’s the code of the plugin I am using. http://wordpress.pastebin.com/LD2vL9rY

    Avatar of govpatel
    govpatel
    Participant

    @govpatel

    @mercime I replaced the code with the one you have above and still have problem when I click on link in email it sends back and get same message as others Sorry, you must be invited to join this community.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @govpate – check the latest version – http://wordpress.org/extend/plugins/wordpress-mu-secure-invites/
    Which reminds to me to check out the latest update :-) Btw, the code I posted above works at least in WPMU install and WPMU upgraded to WP 3.0

    I have to say that I’ve been trying to get this plugin to work for weeks now with several different configurations. Running WP3 and the latest version of buddy press with no luck.

Viewing 22 replies - 1 through 22 (of 22 total)

You must be logged in to reply to this topic.