Skip to:
Content
Pages
Categories
Search
Top
Bottom

Uninstalling BP

  • Avatar of neil
    neil
    Participant

    @elgorrion

    Hi,
    I have de-activated BP afer struggling to get it to work on a MU install; (I had Admin Bar Mods, Backwards Compatibilty, Template Pack all installed but couldn’t get the admin bar to work – links like edit profile just sent me back to homepage.)
    Also I suspect my hosting isn’t up to it!
    Now I need to get my blog back into the root, as BP seemed to move it into /blog/ subdir.
    What files do I remove or edit?
    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    “BP seemed to move it into /blog/ subdir.”
    BuddyPress did not move anything in your installation, even If you defined BP elsewhere than main blog,

    Backup database, deactivate BP and BP-dependent plugins, then go to your database and delete around 15 tables with : yourprefix_bp_componentname

    If you need to move WP to root, http://codex.wordpress.org/Moving_WordPress – as always, back up your database before attempting the move

    Avatar of neil
    neil
    Participant

    @elgorrion

    So is that a default off MU to install in a /blog/ subdir ?

    Avatar of neil
    neil
    Participant

    @elgorrion

    THanks

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    “So is that a default off MU to install in a /blog/ subdir”
    No, you might have unpacked MU to the /blog/ subdir. I upload WPMU files and folders in root.

    Avatar of neil
    neil
    Participant

    @elgorrion

    I didn’t create that /blog/ subdir, and I know I installed MU in the root, so trying to figure what happened
    I’m sure I saw sth in the BP docs about it moving stuff to /blogs
    To clarify, if I type in my domain the blog is there ok, but if I click on a post title I get domain.com/blog/posttitle
    I originally set permalinks to custom /%postname%; now there is the prefix /blog outside the editable box.- same for catgory and tag base

    I got it! I found the menu to edit permalink structure in MU – it’s not in the settings menu, but in Super Admin – Sites – Edit
    I know I didn’t change it, so something I installed must have done it, if not BP then possibly the category mapping plugin

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    “so something I installed must have done it, if not BP “
    I assure you, definitely not BP :-)

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.