Skip to:
Content
Pages
Categories
Search
Top
Bottom

Upgraded and now nav and sidebar is responsive?????

  • Avatar of bluellipse
    bluellipse
    Participant

    @bluellipse

    I upgraded buddypress and only on my ipad and mobile devices the nav bar is stacking and covering the header. In addition the sidebar moved underneath my postings. Should this be happening? I’m a newbie so if the answer is yes, but you please direct me to documentation to help me adjust this — maybe even get rid of the responsive aspect.

    Thank you.

Viewing 18 replies - 1 through 18 (of 18 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @bluellipse What version did you upgrade from? The BP Default theme has been responsive since BP 1.5 and we’re on BP 1.6.2 so this shouldn’t be a surprise. Are you using a bp-default child theme or using the BP Default theme?

    Avatar of bluellipse
    bluellipse
    Participant

    @bluellipse

    I upgraded from 1.5. And yes I am using a bp-default child theme , but if I switch back to BP Default theme, I still have the same issue.

    Avatar of @ubernaut
    Ben Hansen
    Participant

    @ubernaut

    What you are trying to do isn’t going to be easy (or advisable, in my opinion). It’s probably going to involve extracting an older version on bp default from a much older then current version of buddypress (and probably having to do a lot of modification) or something equally unpleasant. Making something which is designed as responsive unresponsive is a little bit like making a car out of spare parts from a plane (a lot more trouble then it’s typically worth).

    Not trying to judge your motivations at all here but you may want to consider if you can live with a responsive theme as it has a lot of benefits if you can. Mobile device traffic share is growing everyday and i suspect it won’t be long before most web traffic is via mobile devices. In fact google has even issued statements to the fact that there a search benefits for using single responsive design as opposed to distinct layouts for different devices:

    http://googlewebmastercentral.blogspot.com/2012/04/responsive-design-harnessing-power-of.html

    Obviously, i have no idea why you don’t like responsive so maybe that’s all irrelevant but i just thought you might want to consider that.

    Avatar of inkblot
    inkblot
    Participant

    @inkblots

    Hey @bluellipse don’t worry about reverting or any of that other jazz, just try removing the following code from your header.php file near the top;

    Of course, place the updated header.php file in your child theme so that it’s not overwritten on the next update.

    I can’t recall offhand if we’d also deleted anything else, but I’m pretty sure that this will quickly solve your problem.

    Sorry everyone, but the “responsiveness” does look terrible on mobile, at least concerning the BP-Default/child theme, and we killed it off as soon as it showed up and are currently exploring other options for mobile, which is extremely important these days, no doubt about it, but achieving it by making your site into a jumbled mess is most definitely not the way to go here.

    Hope this helps!

    Avatar of inkblot
    inkblot
    Participant

    @inkblots

    Sorry, the code to remove is;

    Avatar of inkblot
    inkblot
    Participant

    @inkblots

    Sorry, the code to remove is;
    ?php if ( current_theme_supports( ‘bp-default-responsive’ ) ) : ?><?php endif; ?

    Avatar of bluellipse
    bluellipse
    Participant

    @bluellipse

    Thanks.

    You mean this code, correct?

    Avatar of bluellipse
    bluellipse
    Participant

    @bluellipse

    Thank you, that worked

    Avatar of inkblot
    inkblot
    Participant

    @inkblots

    @bluellipse it’s not letting me place the code within the reply for some reason, so just find what I’ve been able to post above (it stripped some of it away, such as; meta name=”viewport” content=”width=device-width, initial-scale=1.0″) and remove that entire line of code that exists between the php statements and you should be good to go.

    Avatar of @ubernaut
    Ben Hansen
    Participant

    @ubernaut

    so removing that line of code reverts the entire theme to non responsive then?

    Avatar of inkblot
    inkblot
    Participant

    @inkblots

    Good to hear it, @bluellipse!

    And sorry, BuddyPress Mods, and everyone else, for the multiple replies here that I couldn’t get to work properly with the correct code (backticks, [code][/code], etc.) showing?

    Avatar of inkblot
    inkblot
    Participant

    @inkblots

    @ubernaut that is correct.

    Avatar of @ubernaut
    Ben Hansen
    Participant

    @ubernaut

    nice to know.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @inkblots Apologies for the inconvenience. We’ll get this fixed soon.

    @All Thank you for your patience.

    Avatar of ace200
    ace200
    Participant

    @ace200

    This is exactly what I am looking for.

    Thank you very much ;)

    Avatar of aces
    aces
    Participant

    @aces

    You could try putting the following in you child theme functions.php file
    `function bbg_enqueue_styles() {
    remove_theme_support( ‘bp-default-responsive’ );
    }
    add_action( ‘wp_enqueue_scripts’, ‘bbg_enqueue_styles’, 5 );`

    For more info see: http://buddypress.trac.wordpress.org/ticket/3881#comment:2

    Avatar of Mr Bronze
    Mr Bronze
    Participant

    @mr-bronze

    please aces where exactly do i add it in the function.php file? above or below the content

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @mr-bronze see Boone’s answer in the link Aces gave -
    “call it *after* bp-default registers theme support (after_setup_theme, 10) and *before* the stylesheet is enqueued (wp_enqueue_styles, 10)”

Viewing 18 replies - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.