Skip to:
Content
Pages
Categories
Search
Top
Bottom

1.5: Profile settings doesnt work and cant delete stuff from activity stream. Change language?

  • Profile photo of JesperA
    JesperA
    Member

    @jespera

    Yeah.

    I am using BuddyPress template pack, it worked great so far but when i updated to BuddyPress 1.5 and BuddyPress template pack 1.2, 2 things broke..

    1) When visiting my settings page in my profile, i just get a broken link, http://www.domain.se/members/jespera/settings/ <—- Doesnt seem to work anymore so cant change email and/or notification anymore.

    2) Also, in the activity stream, both sitewide and in the profile, i cant delete any updated in there, there is no delete text in the activity stream items anymore.

    3) Have the localisation/text changed in 1.5 compared to the last stable one? After the update just some of the text is translated and the rest is in english.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Profile photo of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Yes, a lot of text was changed. You’ll need new .mo files

    Profile photo of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Yes, a lot of text was changed. You’ll need new .mo files

    Profile photo of RobotFX
    RobotFX
    Member

    @wattaman

    Same here. Settings doesn’t find the address and I’ve just noticed I don’t have the delete link in the activity entry, too.

    Profile photo of r-a-y
    r-a-y
    Moderator

    @r-a-y

    JesperA – update your custom language file:
    https://codex.buddypress.org/extending-buddypress/customizing-labels-messages-and-urls/ (scroll down to “Updating your custom language file”).

    For the settings problem, try re-running the BP Template Pack wizard. This should copy over the directory “members/single/settings/” to your WP theme.

    If the wizard doesn’t work, manually copy over /plugins/buddypress/bp-themes/bp-default/members/single/settings/ to your WP theme’s directory. See if that fixes your problem.

    Let me know what happens.

    Profile photo of wpmubp.org
    wpmubp
    Participant

    @takuya

    Child themes based on 1.2 won’t probably work well with bp-default from 1.5. I had to rewrite a few of my child themes after updating to 1.5.

    Profile photo of rodrigueswilson
    rodrigueswilson
    Participant

    @rodrigueswilson

    How can I chage wordpress 1.5 language?

    Profile photo of everydayreviews
    everydayreviews
    Member

    @everydayreviews

    ray, moving the settings directory into the main theme directory worked

    Profile photo of JohnP
    JohnP
    Participant

    @johnp

    Same problem here – /settings, /settings/general and /settings/notifications all show a blank page after upgrading to 1.5

    I’ve manually placed the /settings directory from bp-default into my theme/members/single/ as suggested, but with no result.

    Further suggestions would be appreciated.

    Profile photo of JohnP
    JohnP
    Participant

    @johnp

    Sorry, the previous comment is incorrect – if I upload the /settings directory to the ACTIVE theme it works fine.

    Profile photo of laminedj
    laminedj
    Participant

    @laminedj

    I did manually tranfert setting folder and it fix the issue. Thanks for the tip

    Profile photo of jkmills78
    jkmills78
    Participant

    @jkmills78

    This fixed the profile setting issue. Any word yet on how to fix the missing delete link in the activity stream?

    Profile photo of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Read this to add back the delete link in the activity stream:
    https://codex.buddypress.org/releases/1-5-developer-and-designer-information/#theme

    Profile photo of jkmills78
    jkmills78
    Participant

    @jkmills78

    Fixed. Thanks!

    Profile photo of niaconcepts
    niaconcepts
    Member

    @niaconcepts

    I am using wordpress with the buddy press login and when I go to look for the default BP theme I don’t see it. I see all of the other themes however.

    Profile photo of Radmacdaddy
    Radmacdaddy
    Participant

    @radmacdaddy

    @niaconcepts, it is in the plugins folder. NOT the themes folder. plugins/buddypress/bp-themes/bp-default…

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘1.5: Profile settings doesnt work and cant delete stuff from activity stream. Change language?’ is closed to new replies.
Skip to toolbar