Skip to:

Activity Link Redirecting to Home Page

  • In a continuation from this post – – I resolved the member profile URL diverting to the home page, but now I am having the same issue with the Activity Stream.

    My website is I usually have this password protected but have left it open whilst I seek assistance.

    In answering the standard questions:

    1. Which version of WordPress are you running? 3.4.1
    2. Did you install WordPress as a directory or subdomain install? Yes – subdomain
    3. If a directory install, is it in root or in a subdirectory?
    4. Did you upgrade from a previous version of WordPress? If so, from which version? No
    5. Was WordPress functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting. – Yes
    6. Which version of BP are you running? The latest version
    7. Did you upgraded from a previous version of BP? If so, from which version? No
    8. Do you have any plugins other than BuddyPress installed and activated? If so, which ones?
    On the subdomain:
    Disqus Comment System
    More Privacy Options
    NB – Deactivating these did nothing.
    9. Are you using the standard BuddyPress themes or customized themes? Default
    10. Have you modified the core files in any way? No other than as per my previous post (above)
    11. Do you have any custom functions in bp-custom.php? Yes – to divert to the subdomain #3
    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in? Latest version as activated through BuddyPress (although I may have reinstalled separately in amongst all of this!)
    13. Please provide a list of any errors in your server’s log files. Please advise how I do this.
    14. Which company provides your hosting? Host Gator
    15. Is your server running Windows, or if Linux; Apache, nginx or something else? Apache

Viewing 14 replies - 1 through 14 (of 14 total)
  • Profile photo of Roger Coathup
    Roger Coathup


    Hey Abbie,

    given the other redirect problem was caused / fixed by an amend in your wp-config file, it would be a good idea to include the content of that file in this thread. Also include contents of your .htaccess.

    Cheers, Roger

    Profile photo of Paul Barthmaier
    Paul Barthmaier


    I’m having a similar issue. I moved BP to a subdomain site on my network. Forums and Groups are fine. Activity and Members do not work. I don’t have anything new in htaccess because it caused infinite looping. For wp-config, I have:

    define(‘WP_DEBUG’, false);
    define(‘WP_ALLOW_MULTISITE’, true);
    define(‘MULTISITE’, true);
    define(‘SUBDOMAIN_INSTALL’, true);
    $base = ‘/';
    define(‘DOMAIN_CURRENT_SITE’, ‘’);
    define(‘PATH_CURRENT_SITE’, ‘/’);
    define(‘SITE_ID_CURRENT_SITE’, 1);
    define(‘BLOG_ID_CURRENT_SITE’, 1);
    define( ‘SUNRISE’, ‘on’ );
    define ( ‘BP_ROOT_BLOG’, 105 );

    My wp-config.php file :

    define (‘WPLANG’, ”);
    define(‘WP_ALLOW_MULTISITE’, true);
    define(‘MULTISITE’, true);
    define(‘SUBDOMAIN_INSTALL’, true);
    $base = ‘/';
    define( ‘DOMAIN_CURRENT_SITE’, ‘’ );
    define( ‘PATH_CURRENT_SITE’, ‘/’ );
    define( ‘SITE_ID_CURRENT_SITE’, 1 );
    define( ‘BLOG_ID_CURRENT_SITE’, 1 );

    I don’t appear to have a .htaccss file however. I’m searching for it and it is saying it is in my top folder but then when I go to look for it I can’t see it. I’m sure there is a trick but I don’t know it!

    Let me know if you want my error log as it is quite long.

    Profile photo of shanebp


    You should Not post, here or anywhere, the password, user name, database, salts or keys from your wp-config file – so unless you swapped out those values before pasting them here – edit that post !

    A .htaccess file starts with a period – often those files are hidden.
    On Windows, you can see hidden files by adjusting ‘folder options’.
    There shouldn’t be anything sensitive in the htaccess file, so you can post it here.

    Use to share your error-log, if you like.

    Thanks Shane!! Edited. Now I will chase up the other two.


    ‘# BEGIN s2Member GZIP exclusions

    RewriteEngine On
    RewriteBase /
    RewriteCond %{QUERY_STRING} (^|?|&)s2member_file_download=.+
    RewriteRule .* – [E=no-gzip:1]

    # END s2Member GZIP exclusions

    ###DirectoryIndex index.php index.htm
    ###IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
    #Redirect /index.htm
    #php_value post_max_size 60M
    #php_value upload_max_filesize 60M
    ##php_value memory_limit 256M
    ##php_value session.save_path /hsphere/local/home/lifestyl/

    #order deny,allow
    ##deny from all
    #allow from all

    #order deny,allow
    #deny from all

    #AuthUserFile /hsphere/local/home/lifestyl/
    #AuthGroupFile /hsphere/local/home/lifestyl/

    #php_value register_globals on


    #RewriteEngine On
    #RewriteBase /
    #RewriteRule ^index.php$ – [L]

    # uploaded files
    #RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    #RewriteCond %{REQUEST_FILENAME} -f [OR]
    #RewriteCond %{REQUEST_FILENAME} -d
    #RewriteRule ^ – [L]
    #RewriteRule . index.php [L]

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]’

    Pastebin isn’t working. I’ve uploaded my error log but now can’t access it to plug in here. Will try again later.

    I’ve edited out your KEYs and SALTs.. those are private, too :)

    13. Please provide a list of any errors in your server’s log files. Please advise how I do this.

    Your web host can help you with this.

    Your BP site is (obv.) running on a site in your multisite network. This won’t have site ID = 1 in your network ( will be site ID = 1).

    Did you set BP_ROOT_BLOG in your config file (just like Pali Baacsi’s done)? If not, can you try this please?

    After you’ve put that in, you may need to re-assign the pages components in the BP settings.

    Yep – have done this -‘ define ( ‘BP_ROOT_BLOG’, 3 )’ I did this almost straight away. Should I still need to reassign this?

    My Error Log Paste is too big for paste bin!! If you need it I’ll set up a dropbox link.

    Thanks for the edit Paul – I’m certainly learning a lot!

    I only asked because it wasn’t in your wp-config.php snippet above :) If 3 is the ID of your “lecabinet” site, that should be correct (assuming you’ve put it in wp-config.php).

    After you’ve put that in, you may need to re-assign the pages components in the BP settings.

    Have you done this since setting the BP_ROOT_BLOG?

    Yes thanks Paul. I did this all originally. I think the issue has come about from installing plugins. I have done a few things since then, but I don’t think this should be the issue. I’d love to be able to completely delete & reinstall BuddyPress, but I did try this, including deleting all the items from the database, and nothing happened so I’m hoping another fix can come about.

    Here is a link to the error log although not sure if you’ll be able to open it.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Activity Link Redirecting to Home Page’ is closed to new replies.
Skip to toolbar