Skip to:

Admin Blog + Custom Homepage [SOLVED]

  • Here’s what I’m trying to do:

    Site URL: (I enabled sub-domains during install)

    I’d like the Admin Blog to show up with the “latest posts” at:

    Custom Homepage:
    WORKS – I created a custom homepage template and created a page called Home via the dashboard, which uses the homepage template. Under Settings > Reading > I set it to use the “Home” page instead of the “latest posts”.

    The problem I’m running into is that I can’t get figure out how to configure *** Dashboard > Site Admin > Blogs > Edit Blog – *** to use for the Admin Blog URL and show the latest posts — though is working fine (would prefer to see: ).

    Is it possible to do what I have in mind without creating a new sub-domain blog? I see that what I’m trying to do works on @apeatling‘s, but using a sub-directory setup (see: Home, Blog menu links).

Viewing 6 replies - 1 through 6 (of 6 total)

  • @mercime


    From what I can see, is posted from the main site and not in a subdirectory blog like you think it is. The /blog/ navigation comes from default theme this using the “blog” slug you see in lines 74-76

    “Is it possible to do what I have in mind without creating a new sub-domain blog?”
    If you want the admin blog link in main site’s home page to open up to per your posts above, then no. You would have to create sub-domain blog and post there, then call those admin posts in home page of main site via RSS widget, or query to list posts from your admin blog, etc. and those links would open up to your preferred URL structure above.

    Thanks for your feedback @mercime. I checked the default’s theme header, lines 73-77, and it points to “Blogs” not “Blog” singular. Clicking on the Blogs menu link shows me the blogs in the network — not the latest posts.

    I’m open to doing it the way does, but I can’t seem to get both /blog (“latest posts” page) and a custom homepage to work hand-in-hand. I have a feeling it’s something simple I don’t have configured properly. When I previously installed wpmu with sub-directories I was getting the following URL … going to /blog would redirect to the site’s front page.

    Disclaimer: I’m new to wpmu and buddypress, though I do have experience with single wordpress installs.



    @r-a-y So close… I followed the instructions:
    1) Login to the WP backend, navigate to “Pages > Add New”. Create an empty, new page called “News” or “Blog” or whatever you want. This page will contain the blog updates.
    2) Under “Settings > Reading”, set front page to “Activity Stream” and your posts page to the new page that you just created.

    Using: Default BP Theme
    Front page shows “Activity Sream” but the new “Blog” page I created shows a normal page similar in format to the About page, not the blog’s latest posts.

    Page attributes:
    Parent > Main Page (no parent)
    Template > Default Template
    Order > 0

    @r-a-y Got it working! The instructions you gave are correct. I didn’t realize that both “Front page” AND “Posts page” under Settings > Reading had to be altered. I originally only altered the Front page.

    Working solution:
    Front page set to “Activity Stream”
    Posts page set to “Blog”

    Thanks @r-a-y!



    No problem, @agrundner!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Admin Blog + Custom Homepage [SOLVED]’ is closed to new replies.
Skip to toolbar