Skip to:

Avatar Upload Problems

  • karthik_kastury


    Whenever I try to upload a new avatar i get this

    Upload Failed! Error was: The uploaded file could not be moved to the upload folder.

    I guess its something due to incorrect permissions.. checking the wp-content folder i see that folder and all folders and files in it have owner set to nobody. is that the way it should be..

    what should i do?

Viewing 5 replies - 1 through 5 (of 5 total)

  • MartinNr5


    My host have this problem as well. Set your permissions to 777 (full access) on the “blogs.dir” folder in “wp-content” just to be sure and test again. That way it doesn’t matter who owns the folder.

    I needed to manually do this for every folder that got created below the “blogs.dir” folder until the uploads worked.

    blogs.dir and some other folders will probably need to be chown’d to the user and group that runs the webserver. Apache2 by default (I think) uses the nobody user account, so I’m assuming that’s what your host uses.

    Whilst 777 will let everything access it, from a security perspective, you should really go for 755 permissions and check that the owner/group of the files is the same as that of the webserver.

    BTW if you’d have tested uploading an avatar on a plain WordPress MU install, you’d have had exactly the same problem. This isn’t buddypress.



    Okay so i followed the instructions here .. here’s what I did..

    # chown nobody -R blogs.dir
    # chgrp nobody -R blogs.dir
    # find blogs.dir -type f -print -exec chmod 644 {} ;
    # find blogs.dir -type d -print -exec chmod 755 {} ;

    but it still doesn’t seem to work… any idea what to do?



    As I mentioned above, start with 777 to see if that helps (“chmod -R 777 blogs.dir”). If so then you know that it has to do with permissions on the folders. Then you need to find out, as DJpaul mentions, what user needs to own the folder.

    The “nobody” user is most likely not the one as that is the current owner when you get the error. In my case I had to reset the owner from “httpd” (the webserver) to my own account. How you do this varies – in my case I had to run a script provided by my host.

    Try and set the owner and group to the user/account you log into the server with, then reset the permissions to 755 and check if it still works.



    I had the same problem and managed to fix via chmod, chown, chgrp; it works perfectly now. Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Avatar Upload Problems’ is closed to new replies.
Skip to toolbar