Skip to:

BP 1.2.4 and WP 3.0 – Blank wp-admin with multisite enabled.

  • deadlyhifi


    I’ve been experimenting today with WP 3.0 RC3 and BP 1.2.4

    I can get BP to word fine on a single site install, but as soon as I enable Multisite the /wp-admin fails, in that I get a blank screen. The site frontend works fine.

    I then experimented with creating a 2nd blog, disabling multisite, enabling BP, then re-enabling multisite. wp-admin then fails on blog 1, but works on blog 2. That is until I enable BP as ‘network enable’ on blog 2. Then blog2 wp-admin also fails. Both front ends work.

    Basically, BP doesn’t like multisite to be enabled.

    With `define(‘WP_DEBUG’, true);` I get plenty of deprecated errors, such as: clean_url is deprecated since version 3.0! Use esc_url() instead, is_site_admin is deprecated since version 3.0! Use is_super_admin() instead. Though they also appear with multisite disabled.

    Is it just that RC3 needs more work? Any ideas?

    [edit – changed BP version to 1.2.4 from 1.4.2 because I got the numbers the wrong way round ;) ]

Viewing 10 replies - 1 through 10 (of 10 total)

  • @mercime


    Full support for WP 3.0 will be in BP 1.3 –
    In the meantime, BP working well in WP/MU 2.9.2

    No, no.

    BuddyPress 1.2.4 onwards should/is meant to work fine with WordPress 3.0. If it doesn’t, it’s a bug we need you to report at so that we can fix it for the next build. BuddyPress 1.3 will require WordPress 3.0, and won’t work with any previous version of WordPress.

    Similar issue as Tom…

    On my local MAMP environment, I set up WP 3.0 RC3 and BP1.4.2.1 (running on MySQL Server version: 5.1.37 and PHP Version 4). Smooth sailing – I can access /wp-admin and site administration works properly.

    When I attempted to set up the same configuration (WP 3.0 RC3 and BP1.4.2.1) on my remote hosted environment (running on MySQL Server version: 5.0.77 and PHP Version 5.2.13), as soon as I click the ‘activate’ link for the BuddyPress plugin from the Site Administration area, the browser attempts to load the following URL:
    but only displays a blank page.

    All further attempts to access the /wp-admin pages results in the blank page.

    If I navigate to the site front end, I’ll see the default theme and then at the bottom of the page, the un-styled textual content of the BP installation. See here:

    If I manually delete the BuddyPress directory from my server, I’m able to access the site administration area again.

    I’ve tried a few variations:
    – WP 2.9.2 + BP – same issue on remote server
    – WP 3.0 RC3 nightly build + BP – same issue on remote server

    Is this an issue with the version of PHP/MySQL running on my remote hosted environment?



    @DJPaul – I understand. However, having tested in dev installs to WP 3.0 RC2 and not getting the smooth experience I have on WPMU 2.9.2 with BP and with all preferred BP plugins working; I can only recommend using WP 3.0 with BP in test/dev installs and not in production/live installs.

    There are 5 ways to test BuddyPress with WordPress 3.0 and I’ve tested four of those configs:
    1) WP 3.0 single (new install) – “Page Not Found” for BP components. Preferred BP plugins not working as they have not been upgraded to work with WP 3.0.
    2) WP 3.0 multisite subdomain (new install) – “Page Not Found” for BP components. Enable MULTIBLOG renders BP links in subsites to go to home page. preferred BP plugins not working as they have not been upgraded to work with WP 3.0
    3) WP 3.0 multisite subdirectory – did not test – I’ve heard that this set up is working for some friends and per posting in forums
    4) WPMU 2.9.2 subdirectory upgraded to WP 3.0 – same as #2 above
    5) WPMU 2.9.2 subdomain upgraded to WP 3.0 – same as #2 above

    Maybe I’ll try to test the 4 configs I have for WP RC3 and see what happens this weekend or next.



    OK, a bit more testing. I tried it on another server and it’s working fine there. The difference being that was WP RC1, so I upgraded it to RC3 and it still works.

    So I put RC1 on the original server and the same problem exists.

    Server 1 = PHP Version 5.2.12
    Server 2 = PHP Version 4.4.8

    then tried Server 2 with PHP 5.2.6, still works fine.

    Major differences are memory_limit S1: 48M S2: 99M
    And S1 has suhosin installed (I can’t find any evidence of suhosin being a problem on a quick Google search).

    Could it be down to the memory limit? I just want to make sure it’s not a problem at my end before reporting in trac. Thanks for your replies everyone.

    You will be told that WP/BP requires inordinate amounts of script memory so it makes sense to eliminate that from the equation right off the bat, increase it to at least 64M more preferably.

    Sadly I’m not expecting any notion of a smooth or comfortable progression to WP 3.0; I’m running a test install of WP 3.0 rc3 with, not put it through it’s paces but with activity stream failing if set as home page for starters I’m inclined to wait for BP 1.2.5 to start actually testing how many plugins will work without mods.



    Upgraded the memory_limit to 96M, then down to 64M. Both work.

    Perhaps the page needs this mentioning?

    Memory requirements vary from server to server so we can’t declare a minimum requirement as it probably will be inaccurate. It’s probably worth mentioning that WordPress 3.0 itself gets very close to 32Mb on a typical server (there was a ticket in the wordpress trac).

    Upgraded my memory limit to 64MB and that solved the issue for me as well.

    James Reyes


    I had the same issue. No matter what, after activating BP I would get blank admin screens.

    I am running on RackSpace Cloud Sites. By running phpinfo I discovered the default memory limit was 34MB. I simply raised the memory limit to 64MB via htaccess and was in business.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘BP 1.2.4 and WP 3.0 – Blank wp-admin with multisite enabled.’ is closed to new replies.
Skip to toolbar