Skip to:
Content
Pages
Categories
Search
Top
Bottom

BP 1.7 Theme Compatibility is not working on my theme

Viewing 7 replies - 1 through 7 (of 7 total)
  • Profile photo of Hugo
    Hugo
    Moderator

    @hnla

    And it still is very promising and delivering :)

    Please explain why your theme isn’t compatible, what are your circumstances? new install upgrade previously template packed a little detail will help.

    Profile photo of dutchy75
    dutchy75
    Participant

    @reneappeldoorn

    Thanks for your reply, you’re right Hugo. Almost everything is working out-of-the-box (new install), except for instance the ‘create new group’ button which is missing. So it’s not thát bad at all..

    Profile photo of @mercime
    @mercime
    Keymaster

    @mercime

    the ‘create new group’ button which is missing

    @reneappeldoorn that’s because in your theme the page title is located outside the WP loop.  You can create a link for Group creation url  example.com/groups/create

    In the same vein, if you’re on multisite and allowing users to create blogs, then you’d also need to create a link example.com/blogs/create

    Profile photo of dutchy75
    dutchy75
    Participant

    @reneappeldoorn

    Thanks @mercime, I told the theme creator about it. He changed a little code in page.php, and yes, the create group button suddenly appeared! Thanks for your help guys.

    Next project: finding out how to add styling to BP pages. I can’t find any documentation on how to do this with the new 1.7 version – assuming it is different from the previous versions?

    You can just add the CSS you want to your theme’s style.css. Should be as easy as that!

    Profile photo of Hugo
    Hugo
    Moderator

    @hnla

    There is documentation! it’s in the documentation section of the site.

    https://codex.buddypress.org/developer/theme-development/a-quick-look-at-1-7-theme-compatibility/

    However as Paul says or:

    Copy over the stylesheet from /bp-templates/bp-legacy/css/buddypress.css to your theme /css/ that will override the original copy, either add to that sheet or start from scratch but for simple changes do as Paul says and work in styles.css

    Profile photo of dutchy75
    dutchy75
    Participant

    @reneappeldoorn

    Thans guys, very helpful.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘BP 1.7 Theme Compatibility is not working on my theme’ is closed to new replies.